123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127 |
- #!/bin/bash
- # Slackware build script for sbagen
- # Copyright 2016 Ruan K. F <ruan.klein@gmail.com>
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # 20220322 bkw: Modified by SlackBuilds.org: fix 32-bit build.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=sbagen
- VERSION=${VERSION:-1.4.5}
- BUILD=${BUILD:-2}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- DOCS="COPYING.txt ChangeLog.txt README.txt SBAGEN.txt TODO.txt focus.txt focus2.txt holosync.txt theory.txt theory2.txt wave.txt"
- BINNAME=${PRGNAM}-bin
- # For MP3 and OGG support, set this to "yes"
- NONFREE=${NONFREE:-no}
- RIVERSOUNDS="sbagen-river-1.4.1.tgz"
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586
- ;;
- x86_64) ARCH=x86_64
- ;;
- *) ARCH=$(uname -m) # bad
- ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tgz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
- # 20220323 bkw: for some reason, inlining the calcNow() function
- # causes the build to fail on 32-bit.
- patch -p1 < $CWD/no_inline_calcnow.diff
- if [ "$NONFREE" = "yes" ]; then
- LIBS="/usr/lib${LIBDIRSUFFIX}/libvorbisidec.so.1 /usr/lib${LIBDIRSUFFIX}/libmad.so"
- OPT="${SLKCFLAGS} -DT_LINUX -DOGG_DECODE -DMP3_DECODE -Wall -s -lm -lpthread"
- rm -f river{1,2}.ogg
- # original river sounds
- tar -xvf $CWD/$RIVERSOUNDS sbagen-1.4.1/river{1,2}.ogg --strip=1
- else
- LIBS=""
- OPT="${SLKCFLAGS} -DT_LINUX -Wall -s -lm -lpthread"
- fi
- # build
- gcc $OPT $LIBS sbagen.c -o $BINNAME || exit 1;
- mkdir -p $PKG/usr/{bin,doc/$PRGNAM-$VERSION,share/$PRGNAM/src}
- cp -ar $DOCS examples \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cp -ar scripts river{1,2}.ogg \
- $PKG/usr/share/$PRGNAM
- # 20220323 bkw: why are we installing the source?
- cp -ar *.c mk-* libs \
- $PKG/usr/share/$PRGNAM/src
- install -m0755 -oroot -groot $CWD/$PRGNAM $PKG/usr/bin
- install -m0755 -oroot -groot $BINNAME $PKG/usr/bin/$BINNAME
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|