123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141 |
- #!/bin/bash
- # Slackware build script for mac
- # Originally written by Luis Henrique <email removed>
- # Now maintained by B. Watson <yalhcru@gmail.com>
- # Original version of this script had no license. Modified version
- # licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/
- # for details.
- # 20211125 bkw: BUILD=2
- # - add -DSHNTOOL to CXXFLAGS, which enables human-readable
- # error messages (but not shn support).
- # - add README note about 'invalid input file' error.
- # - update README and slack-desc.
- # - add man page.
- # 20190107 bkw:
- # - download URL went away, use netbsd pkgsrc
- # - add FORCE_SLACK_CFLAGS option (probably nobody needs it)
- # 20180105 bkw:
- # - take over maintenance
- # - update for 3.99_u4_b5_s7 (BUILD=1)
- # - add ASM environment variable
- # - don't install INSTALL in doc dir
- # - get rid of .la file
- # - minor script simplification
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=mac
- VERSION=${VERSION:-3.99_u4_b5_s7}
- BUILD=${BUILD:-2}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- # If we're on x86 or x86_64, with MMX support, there's optimized
- # assembly code we can use. If ARCH is unknown, or if ASM=no in
- # the environment, disable it.
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- ASM=${ASM:-yes}
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- ASM=${ASM:-yes}
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- ASM=${ASM:-yes}
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- ASM=${ASM:-no}
- fi
- set -e
- SRCVER=${VERSION//_/-}
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$SRCVER
- tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
- cd $PRGNAM-$SRCVER
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- if [ "${FORCE_SLACK_CFLAGS:-no}" = "yes" ]; then
- sed -i 's,-O3\>,,' configure
- fi
- patch -p1 < $CWD/gcc6.patch
- # This option isn't well explained... it turns on human-readable error
- # messages (without it, you get "Error: 1002", no idea WTF it means),
- # and the -q (quick verify) option. It does *not* make mac able to
- # read/write .shn files... I would never have known any of this from
- # reading the docs, had to read the source.
- SLKCFLAGS+=" -DSHNTOOL"
- # Clean up the usage output a little.
- sed -i -e 's,\[EXE\],mac,' \
- -e 's,mac\.exe,mac,' \
- -e 's,int filenames,filenames w/spaces,' \
- src/Console/Console.cpp
- LDFLAGS="-Wl,-s" \
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --enable-shared=yes \
- --enable-static=no \
- --enable-assembly=$ASM \
- --build=$ARCH-slackware-linux
- make all
- make install DESTDIR=$PKG
- # We don't need this:
- rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.la
- # 20211125 bkw: man page by SlackBuild author. I got bored, sorry.
- mkdir -p $PKG/usr/man/man1
- gzip -9c < $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
- PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
- mkdir -p $PKGDOC
- cp -a AUTHORS src/License.htm ChangeLog* NEWS README TODO $PKGDOC
- cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|