scipy3.SlackBuild 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. #!/bin/bash
  2. # Build script for the Python SciPy package to be used with python 3
  3. # Copyright 2016-2019 Serban Udrea <s.udrea@gsi.de>
  4. # Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification,
  8. # is permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
  14. # IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
  15. # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
  16. # DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
  17. # INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
  18. # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
  19. # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
  20. # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
  21. # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
  22. # IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
  23. # POSSIBILITY OF SUCH DAMAGE.
  24. # Written by Eugene Suter <easuter@gmail.com>
  25. # Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
  26. # Updated up to 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
  27. # Added support for building with debugging symbols (S. Udrea)
  28. cd $(dirname $0) ; CWD=$(pwd)
  29. PRGNAM="scipy3"
  30. SRCNAM="scipy"
  31. VERSION=${VERSION:-1.8.0}
  32. BUILD=${BUILD:-1}
  33. TAG=${TAG:-_SBo}
  34. PKGTYPE=${PKGTYPE:-tgz}
  35. if [ -z "$ARCH" ]; then
  36. case "$( uname -m )" in
  37. i?86) ARCH=i586 ;;
  38. arm*) ARCH=arm ;;
  39. *) ARCH=$( uname -m ) ;;
  40. esac
  41. fi
  42. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  43. # the name of the created package would be, and then exit. This information
  44. # could be useful to other scripts.
  45. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  46. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  47. exit 0
  48. fi
  49. TMP=${TMP:-/tmp/SBo}
  50. PKG=${PKG:-$TMP/package-$PRGNAM}
  51. OUTPUT=${OUTPUT:-/tmp}
  52. set -e
  53. rm -rf $PKG
  54. mkdir -p $TMP $PKG $OUTPUT
  55. cd $TMP
  56. rm -rf "$SRCNAM-$VERSION"
  57. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  58. cd "$SRCNAM-$VERSION"
  59. chown -R root:root .
  60. find -L . \
  61. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  62. -exec chmod 755 {} \; -o \
  63. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  64. -exec chmod 644 {} \;
  65. DEBUG=${DEBUG:-no}
  66. DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
  67. if [ "$DEBUG" = "N" ]
  68. then
  69. python3 setup.py install --root $PKG
  70. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  71. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  72. else
  73. python3 setup.py build --debug
  74. python3 setup.py install --root $PKG
  75. fi
  76. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  77. cp -a LICENSE.txt HACKING.rst.txt PKG-INFO \
  78. $PKG/usr/doc/$PRGNAM-$VERSION
  79. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  80. find $PKG/usr/doc -type f -exec chmod 0644 {} \;
  81. mkdir -p $PKG/install
  82. cat $CWD/slack-desc > $PKG/install/slack-desc
  83. cd $PKG
  84. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE