PhyML.SlackBuild 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181
  1. #!/bin/bash
  2. # Slackware build script for PhyML
  3. # Copyright 2011-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Thanks to Niels Horn for some handy modifications and corrections.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=PhyML
  25. VERSION=${VERSION:-3.3.20200621}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. SRCNAM=$(echo $PRGNAM | tr A-Z a-z)
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $SRCNAM-$VERSION
  65. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  66. cd $SRCNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # This is PhyML, the main component of the package. If this is all you want, you
  74. # can comment out the sections that build PhyML MPI and Phyrex below.
  75. ./autogen.sh
  76. ./configure \
  77. --prefix=/usr \
  78. --libdir=/usr/lib${LIBDIRSUFFIX} \
  79. --sysconfdir=/etc \
  80. --localstatedir=/var \
  81. --mandir=/usr/man \
  82. --enable-phyml \
  83. --docdir=/usr/doc/$PRGNAM-$VERSION \
  84. --build=$ARCH-slackware-linux
  85. # Use our CFLAGS
  86. sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
  87. # The -mfma flag is needed for building on 14.2. Help is from here:
  88. # https://github.com/horovod/horovod/issues/1832
  89. CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
  90. make install DESTDIR=$PKG
  91. # This is PhyML MPI. If you do not want it, comment the lines below. Then you do
  92. # not need to install openmpi.
  93. ./autogen.sh
  94. ./configure \
  95. --prefix=/usr \
  96. --libdir=/usr/lib${LIBDIRSUFFIX} \
  97. --sysconfdir=/etc \
  98. --localstatedir=/var \
  99. --mandir=/usr/man \
  100. --enable-mpi \
  101. --docdir=/usr/doc/$PRGNAM-$VERSION \
  102. --build=$ARCH-slackware-linux
  103. # Use our CFLAGS
  104. sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
  105. CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
  106. make install DESTDIR=$PKG
  107. # This is Phyrex
  108. ./autogen.sh
  109. ./configure \
  110. --prefix=/usr \
  111. --libdir=/usr/lib${LIBDIRSUFFIX} \
  112. --sysconfdir=/etc \
  113. --localstatedir=/var \
  114. --mandir=/usr/man \
  115. --enable-phyrex \
  116. --docdir=/usr/doc/$PRGNAM-$VERSION \
  117. --build=$ARCH-slackware-linux
  118. # Use our CFLAGS
  119. sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
  120. CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
  121. make install DESTDIR=$PKG
  122. # This is PhyTime
  123. ./autogen.sh
  124. ./configure \
  125. --prefix=/usr \
  126. --libdir=/usr/lib${LIBDIRSUFFIX} \
  127. --sysconfdir=/etc \
  128. --localstatedir=/var \
  129. --mandir=/usr/man \
  130. --enable-phytime \
  131. --docdir=/usr/doc/$PRGNAM-$VERSION \
  132. --build=$ARCH-slackware-linux
  133. # Use our CFLAGS
  134. sed -i "/^CFLAGS/s/=/+=/" Makefile src/Makefile
  135. CFLAGS="$SLKCFLAGS -mfma" CXXFLAGS="$SLKCFLAGS -mfma" make
  136. make install DESTDIR=$PKG
  137. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  138. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  139. # Include some examples
  140. mkdir -p $PKG/usr/share/$PRGNAM
  141. cp -a examples $PKG/usr/share/$PRGNAM
  142. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  143. cp -a \
  144. doc/{$SRCNAM-manual.pdf,ref.bib,$SRCNAM-manual.tex,fig} COPYING README.md \
  145. $PKG/usr/doc/$PRGNAM-$VERSION
  146. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  147. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  148. mkdir -p $PKG/install
  149. cat $CWD/slack-desc > $PKG/install/slack-desc
  150. cd $PKG
  151. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE