xlog.SlackBuild 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129
  1. #!/bin/bash
  2. # SlackBuild script for xlog.
  3. #
  4. # Copyright 2010 Howard Pepper <h_pepper {at} bellsouth [dot] net>
  5. # Copyright 2017 Nate Bargmann <n0nb@arrl.net>
  6. # Copyright 2020 JK Wood <joshuakwood@gmail.com>
  7. # All rights reserved.
  8. #
  9. # Redistribution and use of this script, with or without modification, is
  10. # permitted provided that the following conditions are met:
  11. #
  12. # 1. Redistributions of this script must retain the above copyright
  13. # notice, this list of conditions and the following disclaimer.
  14. #
  15. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  16. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  17. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  18. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  19. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  20. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  21. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  22. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  23. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  24. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=xlog
  27. VERSION=${VERSION:-2.0.24}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. DOCFILES="AUTHORS COPYING ChangeLog INSTALL NEWS README TODO"
  49. if [ "$ARCH" = "i586" ]; then
  50. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "i686" ]; then
  53. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  54. LIBDIRSUFFIX=""
  55. elif [ "$ARCH" = "x86_64" ]; then
  56. SLKCFLAGS="-O2 -fPIC"
  57. LIBDIRSUFFIX="64"
  58. else
  59. SLKCFLAGS="-O2"
  60. LIBDIRSUFFIX=""
  61. fi
  62. set -e
  63. rm -rf $PKG
  64. mkdir -p $TMP $PKG $OUTPUT
  65. cd $TMP
  66. rm -rf $PRGNAM-$VERSION
  67. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  68. cd $PRGNAM-$VERSION
  69. chown -R root:root .
  70. find -L . \
  71. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  72. -o -perm 511 \) -exec chmod 755 {} \; -o \
  73. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  74. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  75. # As upstreams INSTALL file mentions, packagers should not run
  76. # 'update-mime-database' neither 'update-desktop-database' and
  77. # this should be disabled by default and enabled (if so desired)
  78. # with --enable-mime-update. But...
  79. # Make still runs 'update-desktop-database', creating a new
  80. # index that would overwrite the one on the box receiving the
  81. # package.
  82. # This fixes it in the Makefile.in:
  83. sed "/^@HAVE_DESKTOP_TRUE/s/\(@HAVE_DESKTOP_TRUE@\)/\1@MIMEUPDATE_TRUE@/g" \
  84. -i data/desktop/Makefile.in
  85. CFLAGS="$SLKCFLAGS" \
  86. CXXFLAGS="$SLKCFLAGS" \
  87. ./configure \
  88. --prefix=/usr \
  89. --libdir=/usr/lib${LIBDIRSUFFIX} \
  90. --mandir=/usr/man \
  91. --docdir=/usr/doc/$PRGNAM-$VERSION
  92. make
  93. make install DESTDIR=$PKG
  94. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  95. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  96. find $PKG/usr/man -type f -exec gzip -9 {} \;
  97. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
  98. cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
  99. cp -a data/doc/THANKS $PKG/usr/doc/$PRGNAM-$VERSION
  100. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  101. find $PKG/usr/doc/$PRGNAM-$VERSION/manual -type f -maxdepth 1 -exec rm -f {} \;
  102. sed -i $PKG/usr/share/applications/xlog.desktop \
  103. -e "/^Icon=/s/.png//" \
  104. -e "/^Categories=/s/Utility;Database\(;HamRadio;\)GTK/Network\1/"
  105. mkdir -p $PKG/install
  106. cat $CWD/slack-desc > $PKG/install/slack-desc
  107. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  108. cd $PKG
  109. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE