ucsc-blat.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. #!/bin/bash
  2. # Slackware build script for ucsc-blat
  3. # Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=ucsc-blat
  24. VERSION=${VERSION:-34}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCNAM=blatSuite
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i386 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. set -e
  47. if [ "$ARCH" != "i386" ] && [ "$ARCH" != "x86_64" ]; then
  48. printf "\n\n$ARCH is not supported... \n"
  49. exit 1
  50. fi
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$PRGVER
  55. mkdir $PRGNAM-$PRGVER
  56. cd $PRGNAM-$PRGVER
  57. unzip $CWD/${SRCNAM}.${VERSION}.zip
  58. chown -R root:root .
  59. find -L . \
  60. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  61. -exec chmod 755 {} \; -o \
  62. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  63. -exec chmod 644 {} \;
  64. # Install the precompiled binaries.
  65. install -D -m755 blat $PKG/usr/bin/blat
  66. install -D -m755 faToNib $PKG/usr/bin/faToNib
  67. install -D -m755 faToTwoBit $PKG/usr/bin/faToTwoBit
  68. install -D -m755 gfClient $PKG/usr/bin/gfClient
  69. install -D -m755 gfServer $PKG/usr/bin/gfServer
  70. install -D -m755 nibFrag $PKG/usr/bin/nibFrag
  71. install -D -m755 pslPretty $PKG/usr/bin/pslPretty
  72. install -D -m755 pslReps $PKG/usr/bin/pslReps
  73. install -D -m755 pslSort $PKG/usr/bin/pslSort
  74. install -D -m755 twoBitInfo $PKG/usr/bin/twoBitInfo
  75. install -D -m755 twoBitToFa $PKG/usr/bin/twoBitToFa
  76. install -D -m755 webBlat $PKG/usr/bin/webBlat
  77. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  78. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  79. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  80. cp -a version.doc $PKG/usr/doc/$PRGNAM-$VERSION
  81. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  82. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  83. cat $CWD/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
  84. mkdir -p $PKG/install
  85. cat $CWD/slack-desc > $PKG/install/slack-desc
  86. cd $PKG
  87. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE