onlyoffice-desktopeditors.SlackBuild 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. #!/bin/bash
  2. # Slackware build script for onlyoffice-desktopeditors
  3. # Copyright 2017-2023, Alexander Verbovetsky, Moscow, Russia
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=onlyoffice-desktopeditors
  24. VERSION=${VERSION:-7.3.3}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. if [ "$ARCH" != "x86_64" ]; then
  36. echo "Only x86_64 is supported."
  37. exit 1
  38. fi
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. set -e
  47. rm -rf $PKG
  48. mkdir -p $TMP $PKG $OUTPUT
  49. cd $PKG
  50. ar p $CWD/onlyoffice-desktopeditors_amd64.deb data.tar.xz | tar xvJ
  51. ar p $CWD/onlyoffice-desktopeditors-help_all.deb data.tar.xz | tar xvJ
  52. for s in 16 24 32 48 64 128 256; do
  53. mkdir -p usr/share/icons/hicolor/${s}x${s}/apps
  54. install -m 0644 -o root -g root opt/onlyoffice/desktopeditors/asc-de-${s}.png \
  55. usr/share/icons/hicolor/${s}x${s}/apps/asc-de.png
  56. done
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  64. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  65. mkdir -p usr/doc/$PRGNAM-$VERSION
  66. install -m 0644 opt/onlyoffice/desktopeditors/LICENSE.htm \
  67. opt/onlyoffice/desktopeditors/3DPARTYLICENSE usr/doc/$PRGNAM-$VERSION
  68. rm -f usr/share/doc/onlyoffice-desktopeditors*/changelog.Debian.gz
  69. rmdir usr/share/doc/onlyoffice-desktopeditors* usr/share/doc
  70. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  71. mkdir -p install
  72. cat $CWD/slack-desc > $PKG/install/slack-desc
  73. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  74. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE