gnucash-docs.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114
  1. #!/bin/bash
  2. # Slackware build script for gnucash-docs
  3. # Copyright 2018, 2019, 2020, 2021, 2022 Lenard Spencer, Orlando, Florida, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=gnucash-docs
  24. VERSION=${VERSION:-4.11}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. # Docs only, no binaries
  29. ARCH=noarch
  30. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  31. # the name of the created package would be, and then exit. This information
  32. # could be useful to other scripts.
  33. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  34. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  35. exit 0
  36. fi
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. DOCLANG=${DOCLANG:-"C"}
  41. set -e
  42. rm -rf $PKG
  43. mkdir -p $TMP $PKG $OUTPUT
  44. cd $TMP
  45. rm -rf $PRGNAM-$VERSION
  46. tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
  47. cd $PRGNAM-$VERSION
  48. chown -R root:root .
  49. find -L . \
  50. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  51. -o -perm 511 \) -exec chmod 755 {} \; -o \
  52. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  53. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  54. if [ "${MOBI:-no}" = "yes" ]; then
  55. WITHMOBI="-DWITH_MOBI=ON"
  56. else
  57. WITHMOBI=""
  58. fi
  59. mkdir -p build
  60. cd build
  61. cmake \
  62. -DCMAKE_INSTALL_PREFIX=/usr \
  63. $WITHMOBI \
  64. -DCMAKE_BUILD_TYPE=Release ..
  65. make
  66. if [ "${HTML:-no}" = "yes" ]; then
  67. make $DOCLANG-gnucash-guide-html || make C-gnucash-guide-html
  68. make $DOCLANG-gnucash-help-html || make C-gnucash-help-html
  69. fi
  70. if [ "$MOBI" = "yes" ]; then
  71. make $DOCLANG-gnucash-guide-mobi || make C-gnucash-guide-mobi
  72. make $DOCLANG-gnucash-help-mobi || make C-gnucash-help-mobi
  73. elif [ "${EPUB:-no}" = "yes" ]; then
  74. make $DOCLANG-gnucash-guide-epub || make C-gnucash-guide-epub
  75. make $DOCLANG-gnucash-help-epub || make C-gnucash-help-epub
  76. fi
  77. if [ "${PDF:-no}" = "yes" ]; then
  78. make $DOCLANG-gnucash-guide-pdf || make C-gnucash-guide-pdf
  79. make $DOCLANG-gnucash-help-pdf || make C-gnucash-help-pdf
  80. fi
  81. make install DESTDIR=$PKG
  82. # Move the files to where they belong:
  83. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  84. cp -Rv share/doc/$DOCLANG/* $PKG/usr/doc/$PRGNAM-$VERSION
  85. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  86. # There is no help system for Japanese, so:
  87. if [ "$DOCLANG" = "ja" ]; then
  88. cp -Rv share/doc/C/gnucash-help* $PKG/usr/doc/$PRGNAM-$VERSION
  89. fi
  90. mv $PKG/usr/share/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
  91. # get rid of unused folders:
  92. rm -rf $PKG/usr/share/{$PRGNAM,doc}
  93. cd ..
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cd $PKG
  97. /sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE