icewm.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133
  1. #!/bin/bash
  2. # Slackware build script for icewm
  3. # Copyright 2006-2021, Robby Workman, Tuscaloosa, Alabama, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=icewm
  24. VERSION=${VERSION:-3.3.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tar.lz
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  68. -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  70. -exec chmod 644 {} \;
  71. # Tweak default configs for keybindings and power management commands
  72. patch -p1 < $CWD/patches/tweak-default-configs.diff
  73. CFLAGS="$SLKCFLAGS" \
  74. CXXFLAGS="$SLKCFLAGS" \
  75. ./configure \
  76. --prefix=/usr \
  77. --libdir=/usr/lib${LIBDIRSUFFIX} \
  78. --mandir=/usr/man \
  79. --sysconfdir=/etc \
  80. --with-cfgdir=/etc/$PRGNAM \
  81. --with-libdir=/usr/share/$PRGNAM \
  82. --docdir=/usr/doc/$PRGNAM-$VERSION \
  83. --build=$ARCH-slackware-linux \
  84. --enable-corefonts
  85. make
  86. make install DESTDIR=$PKG
  87. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
  88. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  89. gzip -9 $PKG/usr/man/man1/*.1
  90. # Include some extra configs
  91. mkdir -p $PKG/usr/share/icewm
  92. cp $CWD/config/* $PKG/usr/share/icewm
  93. chmod 0755 $PKG/usr/share/icewm/startup
  94. chmod 0755 $PKG/usr/share/icewm/shutdown
  95. # Add xinitrc for xwmconfig(1)
  96. mkdir -p $PKG/etc/X11/xinit
  97. cat $CWD/xinitrc.icewm > $PKG/etc/X11/xinit/xinitrc.icewm.new
  98. chmod 0755 $PKG/etc/X11/xinit/xinitrc.icewm.new
  99. # Add icewm as a session choice for !kdm desktop managers
  100. mkdir -p $PKG/usr/share/xsessions
  101. cat $CWD/icewm.desktop > $PKG/usr/share/xsessions/icewm.desktop
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
  103. cp -a \
  104. AUTHORS COMPLIANCE COPYING ChangeLog NEWS README THANKS TODO VERSION \
  105. $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/icewm.SlackBuild > $PKG/usr/doc/icewm-$VERSION/icewm.SlackBuild
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE