svxlink.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. #!/bin/sh
  2. # Slackware build script for svxlink - cmake version
  3. # Copyright 2014-2015, Gustavo Conrad (gus3963 gmail)
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=svxlink
  23. VERSION=${VERSION:-14.08.1}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i486 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i486" ]; then
  38. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. # get runtime configuration
  51. # invoke script as: QTEL=NO ./svxlink.SlackBuild
  52. # to compile svxlink only, no Qtel
  53. BUILD_QTEL="-DUSE_QT=YES" && [[ "$QTEL" = "NO" ]] && BUILD_QTEL="-DUSE_QT=NO"
  54. set -e
  55. # Bail if user or group isn't valid on your system
  56. if ! grep ^svxlink: /etc/passwd 2>&1 > /dev/null; then
  57. cat << EOF
  58. You must have a svxlink user and group to run this script
  59. # groupadd -g 286 svxlink
  60. # useradd -u 286 -g svxlink -d /var/spool/svxlink -s /bin/false svxlink
  61. EOF
  62. exit
  63. elif ! grep ^svxlink: /etc/group 2>&1 > /dev/null; then
  64. cat << EOF
  65. You must have a svxlink group to run this script
  66. # groupadd -g 286 svxlink
  67. EOF
  68. exit
  69. fi
  70. rm -rf $PKG
  71. mkdir -p $TMP $PKG $OUTPUT
  72. cd $TMP
  73. rm -rf $PRGNAM-$VERSION
  74. tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  75. # the Github download unpacks several directories, we only need src
  76. # We will download a larger file but I think it's better this way
  77. # to make the overall process simpler
  78. cd $PRGNAM-$VERSION/src
  79. chown -R root:root .
  80. find -L . \
  81. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  82. -o -perm 511 \) -exec chmod 755 {} \; -o \
  83. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  84. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  85. # Compile the application and install it into the $PKG directory
  86. mkdir -p build
  87. cd build
  88. cmake \
  89. $BUILD_QTEL \
  90. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  91. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  92. -DCMAKE_INSTALL_PREFIX=/usr \
  93. -DSYSCONF_INSTALL_DIR=/etc \
  94. -DLOCAL_STATE_DIR=/var \
  95. -DLIB_SUFFIX=${LIBDIRSUFFIX} \
  96. ..
  97. make
  98. make install DESTDIR=$PKG
  99. cd ..
  100. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  101. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  103. cp -a ../COPYRIGHT doc/README* doc/*.txt doc/qteluserdocs/*.pdf doc/qteluserdocs/*.tex \
  104. $PKG/usr/doc/$PRGNAM-$VERSION
  105. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  106. rm -rf $PKG/usr/share/man
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  110. mkdir -p $PKG/etc/rc.d
  111. cat $CWD/rc.svxlink > $PKG/etc/rc.d/rc.svxlink.new
  112. # Rename .conf to .new to be processed by doinst.sh
  113. rename .conf .conf.new $PKG/etc/svxlink/*
  114. rename .conf .conf.new $PKG/etc/svxlink/svxlink.d/*.conf
  115. cd $PKG
  116. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}