svxlink-sounds-en_US-heather-16k.SlackBuild 2.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. #!/bin/sh
  2. # Slackware build script for svxlink-sounds
  3. # Copyright 2014, Gustavo Conrad - LU8WFY (gus3963 gmail)
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=svxlink-sounds-en_US-heather-16k
  23. SRCNAM=svxlink-sounds-en_US-heather
  24. VERSION=${VERSION:-14.08}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. ARCH=noarch
  28. CWD=$(pwd)
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. set -e
  33. rm -rf $PKG
  34. mkdir -p $TMP $PKG $OUTPUT
  35. mkdir -p $PKG/usr/share/svxlink/sounds/en_US-heather-16k
  36. cd $PKG/usr/share/svxlink/sounds/en_US-heather-16k
  37. tar xvf $CWD/$VERSION.tar.gz --strip-components 1 || \
  38. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz --strip-components 1
  39. chown -R root:root .
  40. find -L . \
  41. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  42. -o -perm 511 \) -exec chmod 755 {} \; -o \
  43. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  44. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  45. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  46. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  47. mkdir -p $PKG/install
  48. cat $CWD/slack-desc > $PKG/install/slack-desc
  49. cd $PKG
  50. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}