postgis.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. #!/bin/sh
  2. # Slackware build script for PostGIS
  3. # Copyright 2009 Peter Sarkoci <sarkoci@math.sk>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Maintained by Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
  23. PRGNAM=postgis
  24. VERSION=${VERSION:-2.2.0}
  25. BUILD=${BUILD:-2}
  26. TAG=${TAG:-_SBo}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i486 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. GUI=${GUI:-yes}
  39. PGADMIN=${PGADMIN:-no}
  40. if [ "$GUI" = "yes" ] ; then
  41. SHP2PGSQL_GUI="--with-gui"
  42. else
  43. PGADMIN=no
  44. fi
  45. if [ "$ARCH" = "i486" ]; then
  46. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. CFLAGS="$SLKCFLAGS" \
  72. CXXFLAGS="$SLKCFLAGS" \
  73. ./configure \
  74. --build=$ARCH \
  75. --prefix=/usr \
  76. --libdir=/usr/lib${LIBDIRSUFFIX} \
  77. --datarootdir=/usr \
  78. --sysconfdir=/etc \
  79. --localstatedir=/var \
  80. $SHP2PGSQL_GUI \
  81. --build=$ARCH-slackware-linux
  82. make -j1
  83. make install DESTDIR=$PKG
  84. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  85. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  86. if [ "$PGADMIN" = "yes" ] ; then
  87. mkdir -p $PKG/usr/share/pgadmin3/plugins.d
  88. cp $CWD/$PRGNAM.ini $PKG/usr/share/pgadmin3/plugins.d
  89. fi
  90. mkdir -p $PKG/usr/bin
  91. pgbindir=$(pg_config --bindir)
  92. cd $PKG/$pgbindir
  93. for f in *; do
  94. base=`basename $f`
  95. echo ln -s $pgbindir/$base $PKG/usr/bin
  96. ln -s $pgbindir/$base $PKG/usr/bin
  97. done
  98. cd -
  99. mkdir -p $PKG/usr/man/man1
  100. cp -a doc/man/* $PKG/usr/man/man1
  101. gzip -9 $PKG/usr/man/man1/*.1
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  103. cp -a COPYING CREDITS ChangeLog NEWS README.postgis TODO $PKG/usr/doc/$PRGNAM-$VERSION
  104. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  105. mkdir -p $PKG/install
  106. cat $CWD/slack-desc > $PKG/install/slack-desc
  107. cd $PKG
  108. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}