osm2pgsql.SlackBuild 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. #!/bin/sh
  2. # Slackware build script for osm2pgsql
  3. # Copyright 2013 Benjamin Trigona-Harany
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=osm2pgsql
  23. VERSION=${VERSION:-0.88.0}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i486 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i486" ]; then
  38. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -e
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$VERSION
  55. if [ -e $CWD/$VERSION.tar.gz ]; then
  56. tar xvf $CWD/$VERSION.tar.gz
  57. else
  58. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  59. fi
  60. cd $PRGNAM-$VERSION
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  64. -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  66. -exec chmod 644 {} \;
  67. ./autogen.sh
  68. CFLAGS="$SLKCFLAGS" \
  69. CXXFLAGS="$SLKCFLAGS" \
  70. ./configure \
  71. --prefix=/usr \
  72. --libdir=/usr/lib${LIBDIRSUFFIX} \
  73. --sysconfdir=/etc \
  74. --localstatedir=/var \
  75. --mandir=/usr/man \
  76. --docdir=/usr/doc/$PRGNAM-$VERSION \
  77. --with-bzip2=/usr/lib${LIBDIRSUFFIX} \
  78. --with-geos=yes \
  79. --with-proj=yes \
  80. --with-zlib=/usr/lib${LIBDIRSUFFIX} \
  81. --with-libxml2=yes \
  82. --with-postgresql=/usr/bin/pg_config \
  83. --build=$ARCH-slackware-linux
  84. make
  85. make install DESTDIR=$PKG
  86. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  87. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  88. gzip -9 $PKG/usr/man/man?/*
  89. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  90. cp -a \
  91. AUTHORS COPYING ChangeLog NEWS README TODO \
  92. $PKG/usr/doc/$PRGNAM-$VERSION
  93. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cd $PKG
  97. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}