topdraw.SlackBuild 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364
  1. #!/bin/sh
  2. # Slackware build script for topdraw
  3. # Copyright 2013 Petar Petrov, petar.petrov@student.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=topdraw
  23. VERSION=${VERSION:-sep2002}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. ARCH=noarch
  27. CWD=$(pwd)
  28. TMP=${TMP:-/tmp/SBo}
  29. PKG=$TMP/package-$PRGNAM
  30. OUTPUT=${OUTPUT:-/tmp}
  31. set -e
  32. rm -rf $PKG
  33. mkdir -p $TMP $PKG $OUTPUT
  34. cd $TMP
  35. rm -rf $PRGNAM-$VERSION
  36. mkdir $PRGNAM-$VERSION
  37. cd $PRGNAM-$VERSION
  38. unzip $CWD/$PRGNAM.zip
  39. install -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
  40. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  41. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  42. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  43. # Couldn't find an icon, so I assembled this thing from the program's menu...
  44. mkdir -p $PKG/usr/share/{applications,pixmaps}
  45. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  46. cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
  47. mkdir -p $PKG/install
  48. cat $CWD/slack-desc > $PKG/install/slack-desc
  49. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  50. cd $PKG
  51. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}