samtools.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. #!/bin/sh
  2. # Slackware build script for samtools
  3. # Copyright 2013 Petar Petrov, petar.petrov@student.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # With help about the install paths from Arch Linux AUR:
  23. # https://aur.archlinux.org/packages/sa/samtools/PKGBUILD
  24. PRGNAM=samtools
  25. VERSION=${VERSION:-0.1.19}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i486 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. CWD=$(pwd)
  36. TMP=${TMP:-/tmp/SBo}
  37. PKG=$TMP/package-$PRGNAM
  38. OUTPUT=${OUTPUT:-/tmp}
  39. if [ "$ARCH" = "i486" ]; then
  40. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  41. LIBDIRSUFFIX=""
  42. elif [ "$ARCH" = "i686" ]; then
  43. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  44. LIBDIRSUFFIX=""
  45. elif [ "$ARCH" = "x86_64" ]; then
  46. SLKCFLAGS="-O2 -fPIC"
  47. LIBDIRSUFFIX="64"
  48. else
  49. SLKCFLAGS="-O2"
  50. LIBDIRSUFFIX=""
  51. fi
  52. set -e
  53. rm -rf $PKG
  54. mkdir -p $TMP $PKG $OUTPUT
  55. cd $TMP
  56. rm -rf $PRGNAM-$VERSION
  57. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  58. cd $PRGNAM-$VERSION
  59. chown -R root:root .
  60. find -L . \
  61. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  62. -o -perm 511 \) -exec chmod 755 {} \; -o \
  63. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  64. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  65. # Use our CFLAGS/CXXFLAGS
  66. sed -i "/^C.*.*FLAGS/s/=/+=/" Makefile
  67. CFLAGS="$SLKCFLAGS" \
  68. make
  69. make razip
  70. # Install samtools, razip and bam library
  71. install -D -m755 samtools $PKG/usr/bin/samtools
  72. install -D -m755 razip $PKG/usr/bin/razip
  73. install -D -m644 libbam.a $PKG/usr/lib${LIBDIRSUFFIX}/libbam.a
  74. # Install bcftools its library and vsfutils
  75. cd bcftools
  76. install -D -m755 bcftools $PKG/usr/bin/bcftools
  77. install -D -m644 libbcf.a $PKG/usr/lib${LIBDIRSUFFIX}/libbcf.a
  78. install -D -m755 vcfutils.pl $PKG/usr/bin/vcfutils.pl
  79. # Include additional executables
  80. cd ../misc
  81. install -D -m755 ace2sam $PKG/usr/libexec/$PRGNAM/ace2sam
  82. install -D -m755 bamcheck $PKG/usr/libexec/$PRGNAM/bamcheck
  83. install -D -m755 maq2sam-long $PKG/usr/libexec/$PRGNAM/maq2sam-long
  84. install -D -m755 maq2sam-short $PKG/usr/libexec/$PRGNAM/maq2sam-short
  85. install -D -m755 md5fa $PKG/usr/libexec/$PRGNAM/md5fa
  86. install -D -m755 md5sum-lite $PKG/usr/libexec/$PRGNAM/md5sum-lite
  87. install -D -m755 wgsim $PKG/usr/libexec/$PRGNAM/wgsim
  88. # Include some scripts
  89. mkdir -p $PKG/usr/share/$PRGNAM
  90. cp -a \
  91. *.pl *.lua *.py plot-bamcheck \
  92. $PKG/usr/share/$PRGNAM
  93. # Include bam header files
  94. cd ..
  95. mkdir -p $PKG/usr/include/bam
  96. for f in *.h ; do
  97. install -m644 $f "$PKG/usr/include/bam"
  98. done
  99. # Install manpage
  100. install -D -m644 $PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
  101. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  102. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  103. find $PKG/usr/man -type f -exec gzip -9 {} \;
  104. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  105. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  106. cp -a \
  107. AUTHORS COPYING INSTALL NEWS \
  108. $PKG/usr/doc/$PRGNAM-$VERSION
  109. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  110. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  111. # Fix permissions in the package...
  112. find $PKG/usr/{doc,include,share} \
  113. -type d -exec chmod 755 {} \; -o \
  114. -type f -exec chmod 644 {} \;
  115. mkdir -p $PKG/install
  116. cat $CWD/slack-desc > $PKG/install/slack-desc
  117. cd $PKG
  118. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}