pamlX.SlackBuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. #!/bin/sh
  2. # Slackware build script for pamlX
  3. # Copyright 2013-2015 Petar Petrov, petar.petrov@student.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=pamlX
  23. VERSION=${VERSION:-1.3.1}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i486 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i486" ]; then
  38. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -e
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf ${PRGNAM}${VERSION}-src
  55. tar xvf $CWD/${PRGNAM}${VERSION}-src.tgz
  56. cd ${PRGNAM}${VERSION}-src
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. # Fix the path where pamlX looks for the paml executables, its config
  64. # file (if necessary it should be in your home directory) and the
  65. # manuals installed by paml.
  66. sed -i 's|QApplication::applicationDirPath()|"/usr"|g' mainwindow.cpp
  67. sed -i 's|+= "/pamlx.conf"|= "~/.pamlX/pamlx.conf"|g' mainwindow.cpp
  68. sed -i 's|/doc/|/doc/paml-4.8a/|g' mainwindow.cpp
  69. sed -i 's|/doc/|/doc/paml-4.8a/|g' pamlhistorydialog.cpp
  70. # If you want the "Help" menu to use something else than Okular for
  71. # viewing the PDF documentation, uncomment the appropriate line below
  72. # (or add your own if you want a viewer not listed here):
  73. #
  74. # sed -i 's|okular|xpdf|g' mainwindow.cpp # Use XPDF
  75. # sed -i 's|okular|evince|g' mainwindow.cpp # Use Evince
  76. # sed -i 's|okular|acroread|g' mainwindow.cpp # Use Adobe Acrobat Reader
  77. # sed -i 's|okular|epdfviewer|g' mainwindow.cpp # Use ePDFViewer
  78. qmake \
  79. QMAKE_CFLAGS="$SLKCFLAGS" \
  80. QMAKE_CXXFLAGS="$SLKCFLAGS"
  81. make
  82. install -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
  83. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  84. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  85. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  86. cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
  87. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  88. mkdir -p $PKG/usr/share/{applications,pixmaps}
  89. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  90. cp pamlxlogo.png $PKG/usr/share/pixmaps/$PRGNAM.png
  91. # Fix permissions of the documentation control files and examples
  92. find $PKG/usr/{doc,share} -type d -exec chmod 755 {} \; -o \
  93. -type f -exec chmod 644 {} \;
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}