opengrads.SlackBuild 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. #!/bin/sh
  2. # Slackware build script for OpenGrADS
  3. # Copyright 2009 Eduardo Oda
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Written by Oda - edu.oda@gmail.com
  23. PRGNAM=opengrads
  24. VERSION=${VERSION:-2.0.1.oga.1}
  25. ARCH=${ARCH:-i686}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. CWD=$(pwd)
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. set -e
  33. if [ "$ARCH" != "x86_64" ]; then
  34. # Just in case someone has ARCH=i486 set in the environment
  35. ARCH=i686
  36. fi
  37. rm -rf $PKG
  38. mkdir -p $PKG/opt $OUTPUT
  39. tar xvf grads-$VERSION-bundle-$ARCH-*-linux-gnu.tar.gz -C $PKG/opt
  40. cd $PKG/opt
  41. chown -R root:root grads-$VERSION
  42. # Let's use an unversioned install directory for less noisy upgrades
  43. mv grads-$VERSION opengrads
  44. # and then symlink to replicate the original directory structure
  45. ln -s opengrads grads-$VERSION
  46. cd opengrads
  47. find -L . \
  48. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  49. -exec chmod 755 {} \; -o \
  50. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  51. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  52. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  53. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  54. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  55. ( cd $PKG/usr/doc/$PRGNAM-$VERSION
  56. ln -s ../../../opt/opengrads/COPYRIGHT .
  57. ln -s ../../../opt/opengrads/INSTALL .
  58. ln -s ../../../opt/opengrads/NEWS .
  59. ln -s ../../../opt/opengrads/README .
  60. ln -s ../../../opt/opengrads/Contents/Resources/Documentation .
  61. )
  62. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  63. mkdir -p $PKG/etc/profile.d
  64. cp $CWD/opengrads.sh $PKG/etc/profile.d/opengrads.sh
  65. cp $CWD/opengrads.csh $PKG/etc/profile.d/opengrads.csh
  66. chmod 0755 $PKG/etc/profile.d/*
  67. mkdir -p $PKG/install
  68. cat $CWD/slack-desc > $PKG/install/slack-desc
  69. cd $PKG
  70. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}