mafft.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. #!/bin/sh
  2. # Slackware build script for mafft
  3. # Copyright 2013-2015 Petar Petrov, petar.petrov@student.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=mafft
  23. VERSION=${VERSION:-7.221}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i486 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. if [ "$ARCH" = "i486" ]; then
  38. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  39. LIBDIRSUFFIX=""
  40. elif [ "$ARCH" = "i686" ]; then
  41. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  42. LIBDIRSUFFIX=""
  43. elif [ "$ARCH" = "x86_64" ]; then
  44. SLKCFLAGS="-O2 -fPIC"
  45. LIBDIRSUFFIX="64"
  46. else
  47. SLKCFLAGS="-O2"
  48. LIBDIRSUFFIX=""
  49. fi
  50. set -e
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf $PRGNAM-$VERSION-with-extensions
  55. tar xvf $CWD/$PRGNAM-$VERSION-with-extensions-src.tgz
  56. cd $PRGNAM-$VERSION-with-extensions
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. cd core
  64. make clean
  65. CFLAGS="$SLKCFLAGS" \
  66. CXXFLAGS="$SLKCFLAGS" \
  67. PREFIX=/usr \
  68. LIBDIR=/usr/libexec/$PRGNAM \
  69. MANDIR=/usr/man/man1 \
  70. make -e
  71. cd ../extensions
  72. make clean
  73. CFLAGS="$SLKCFLAGS" \
  74. CXXFLAGS="$SLKCFLAGS" \
  75. PREFIX=/usr \
  76. LIBDIR=/usr/libexec/$PRGNAM \
  77. MANDIR=/usr/man/man1 \
  78. make -e
  79. cd ../core
  80. make \
  81. PREFIX=$PKG/usr \
  82. LIBDIR=$PKG/usr/libexec/$PRGNAM \
  83. MANDIR=$PKG/usr/man/man1 \
  84. install
  85. cd ../extensions
  86. make \
  87. PREFIX=$PKG/usr \
  88. LIBDIR=$PKG/usr/libexec/$PRGNAM \
  89. MANDIR=$PKG/usr/man/man1 \
  90. install
  91. cd ..
  92. # Clean up
  93. rm -rf $PKG/usr/libexec/$PRGNAM/{$PRGNAM.1,$PRGNAM-homologs.1}
  94. # Fix two wrong links
  95. ( cd $PKG/usr/bin
  96. rm -f mafft-distance mafft-profile
  97. ln -s /usr/libexec/mafft/mafft-distance mafft-distance
  98. ln -s /usr/libexec/mafft/mafft-profile mafft-profile )
  99. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  100. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  101. find $PKG/usr/man -type f -exec gzip -9 {} \;
  102. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  103. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  104. cp -a \
  105. license license.extensions readme \
  106. $PKG/usr/doc/$PRGNAM-$VERSION
  107. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  108. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  109. # Fix permissions
  110. find $PKG/usr/doc -type f -exec chmod 0644 {} \;
  111. mkdir -p $PKG/install
  112. cat $CWD/slack-desc > $PKG/install/slack-desc
  113. cd $PKG
  114. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}