jalview.SlackBuild 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. #!/bin/sh
  2. # Slackware build script for jalview
  3. # Copyright 2013-2015 Petar Petrov, petar.petrov@student.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # With help from the jalview PKGBUILD at Arch linux AUR:
  23. # https://aur.archlinux.org/packages/jalview/
  24. PRGNAM=jalview
  25. VERSION=${VERSION:-2.9}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. SRCNAM=install-jalview.bin
  29. ARCH=noarch
  30. CWD=$(pwd)
  31. TMP=${TMP:-/tmp/SBo}
  32. PKG=$TMP/package-$PRGNAM
  33. OUTPUT=${OUTPUT:-/tmp}
  34. set -e
  35. rm -rf $PKG
  36. mkdir -p $TMP $PKG $OUTPUT
  37. cd $TMP
  38. rm -rf $PRGNAM-$VERSION
  39. mkdir $PRGNAM-$VERSION
  40. cd $PRGNAM-$VERSION
  41. 7z e $CWD/$SRCNAM
  42. chown -R root:root .
  43. find -L . \
  44. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  45. -o -perm 511 \) -exec chmod 755 {} \; -o \
  46. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  47. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  48. mkdir -p $PKG/usr/share/java/$PRGNAM
  49. cp -a *.jar $PKG/usr/share/java/$PRGNAM
  50. # The wrapper is from Arch. Thank you!
  51. install -D -m755 $CWD/$PRGNAM $PKG/usr/bin/$PRGNAM
  52. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  53. cp -a \
  54. building.html exampleFeatures.txt LICENSE README_IA \
  55. $PKG/usr/doc/$PRGNAM-$VERSION
  56. cat $CWD/TheJalviewTutorial_screen.pdf > $PKG/usr/doc/$PRGNAM-$VERSION/Tutorial.pdf
  57. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  58. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  59. # Menu item and icon
  60. mkdir -p $PKG/usr/share/{applications,pixmaps}
  61. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  62. cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
  63. mkdir -p $PKG/install
  64. cat $CWD/slack-desc > $PKG/install/slack-desc
  65. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  66. cd $PKG
  67. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}