gnucap.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. #!/bin/sh
  2. # Slackware build script for Gnucap
  3. # Copyright 2014 R. S. Ananda Murthy, Mysore, India
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=gnucap
  23. VERSION=${VERSION:-2009-12-07}
  24. PKGVER=20091207
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i486 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i486" ]; then
  39. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -e
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf $PRGNAM-$VERSION
  56. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  57. cd $PRGNAM-$VERSION
  58. chown -R root:root .
  59. find -L . \
  60. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  61. -o -perm 511 \) -exec chmod 755 {} \; -o \
  62. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  63. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  64. CFLAGS="$SLKCFLAGS" \
  65. CXXFLAGS="$SLKCFLAGS" \
  66. ./configure \
  67. --prefix=/usr \
  68. --libdir=/usr/lib${LIBDIRSUFFIX} \
  69. --sysconfdir=/etc \
  70. --localstatedir=/var \
  71. --mandir=/usr/man \
  72. --docdir=/usr/doc/$PKGVER \
  73. --build=$ARCH-slackware-linux
  74. make
  75. make install DESTDIR=$PKG
  76. mkdir -p $PKG/usr/share/icons/hicolor/48x48/apps
  77. cp $CWD/$PRGNAM.png $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
  78. chmod -x $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
  79. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  80. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  81. find $PKG/usr/man -type f -exec gzip -9 {} \;
  82. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  83. mkdir -p $PKG/usr/doc/$PRGNAM-$PKGVER
  84. cp -a AUTHORS COPYING README INSTALL $PKG/usr/doc/$PRGNAM-$PKGVER
  85. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$PKGVER/$PRGNAM.SlackBuild
  86. cp $CWD/$PRGNAM.png $PKG/usr/doc/$PRGNAM-$PKGVER/$PRGNAM.png
  87. cp $PKG/usr/share/gnucap/doc/acs-tutorial $PKG/usr/doc/$PRGNAM-$PKGVER/acs-tutorial
  88. mv $PKG/usr/share/gnucap/examples $PKG/usr/doc/$PRGNAM-$PKGVER/examples
  89. rm -rf $PKG/usr/share/gnucap
  90. mkdir -p $PKG/install
  91. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  92. cat $CWD/slack-desc > $PKG/install/slack-desc
  93. mkdir -p $PKG/usr/share/applications
  94. cat <<EOF > $PKG/usr/share/applications/$PRGNAM.desktop
  95. [Desktop Entry]
  96. Encoding=UTF-8
  97. Name=Gnucap
  98. Comment=True mixed mode circuit simulator
  99. Exec=gnucap
  100. Terminal=true
  101. Type=Application
  102. Categories=Science
  103. Icon=gnucap
  104. StartupNotify=true
  105. EOF
  106. cd $PKG
  107. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$PKGVER-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}