finchtv.SlackBuild 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. #!/bin/sh
  2. # Slackware build script for finchtv
  3. # Copyright 2015 Petar Petrov, petar.petrov@student.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=finchtv
  23. VERSION=${VERSION:-1.3.1}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. SRCVER=1_3_1
  27. ARCH=i386 # This will work on a stock Slackware64 as well.
  28. CWD=$(pwd)
  29. TMP=${TMP:-/tmp/SBo}
  30. PKG=$TMP/package-$PRGNAM
  31. OUTPUT=${OUTPUT:-/tmp}
  32. set -e
  33. rm -rf $PKG
  34. mkdir -p $TMP $PKG $OUTPUT
  35. cd $TMP
  36. rm -rf ${PRGNAM}_${SRCVER}
  37. tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.gz
  38. cd ${PRGNAM}_${SRCVER}
  39. chown -R root:root .
  40. find -L . \
  41. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  42. -o -perm 511 \) -exec chmod 755 {} \; -o \
  43. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  44. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  45. install -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
  46. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  47. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  48. mkdir -p $PKG/usr/share/$PRGNAM
  49. cp -a SampleData $PKG/usr/share/$PRGNAM
  50. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  51. cp -a Help License.txt ReleaseNotes.txt $PKG/usr/doc/$PRGNAM-$VERSION
  52. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  53. cat $CWD/COMPANY > $PKG/usr/doc/$PRGNAM-$VERSION/COMPANY
  54. cat $CWD/CONTACT > $PKG/usr/doc/$PRGNAM-$VERSION/CONTACT
  55. cat $CWD/PRIVACY > $PKG/usr/doc/$PRGNAM-$VERSION/PRIVACY
  56. mkdir -p $PKG/usr/share/{applications,pixmaps}
  57. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  58. cp Help/media/FinchTV_Mac_App.png $PKG/usr/share/pixmaps/$PRGNAM.png
  59. mkdir -p $PKG/install
  60. cat $CWD/slack-desc > $PKG/install/slack-desc
  61. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  62. cd $PKG
  63. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}