cap3.SlackBuild 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. #!/bin/sh
  2. # Slackware build script for cap3
  3. # Copyright 2013 Petar Petrov, ppetrov@paju.oulu.fi
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=cap3
  23. VERSION=${VERSION:-20091029} # Use the last modification date as version
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i386 ;;
  29. arm*) ARCH=arm ;;
  30. *) ARCH=$( uname -m ) ;;
  31. esac
  32. fi
  33. CWD=$(pwd)
  34. TMP=${TMP:-/tmp/SBo}
  35. PKG=$TMP/package-$PRGNAM
  36. OUTPUT=${OUTPUT:-/tmp}
  37. set -e
  38. if [ "$ARCH" != "i386" ] && [ "$ARCH" != "x86_64" ]; then
  39. printf "\n\n$ARCH is not supported... \n"
  40. exit 1
  41. fi
  42. # Determine the tarball arch
  43. if [ "$ARCH" = "x86_64" ]; then
  44. SRCARCH=".opteron64"
  45. else
  46. SRCARCH=""
  47. fi
  48. # Construct tarball name
  49. TARNAME=${PRGNAM}.linux${SRCARCH}
  50. DIRNAM=CAP3
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -fr $DIRNAM
  55. tar xvf $CWD/$TARNAME.tar
  56. cd $DIRNAM
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  60. -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  62. -exec chmod 644 {} \;
  63. install -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
  64. install -D -m755 formcon $PKG/usr/bin/formcon
  65. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  66. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  67. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  68. cp -a \
  69. aceform doc README \
  70. $PKG/usr/doc/$PRGNAM-$VERSION
  71. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  72. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  73. cat $CWD/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
  74. mkdir -p $PKG/install
  75. cat $CWD/slack-desc > $PKG/install/slack-desc
  76. cd $PKG
  77. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}