white_dune.SlackBuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. #!/bin/bash
  2. # Slackware build script for white_dune
  3. # Copyright 2019 J. "MUFTI" Scheurich Stuttgart/Germany
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=white_dune
  24. SRCNAM=wdune
  25. VERSION=${VERSION:-1.876}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $SRCNAM-$VERSION
  64. tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
  65. cd $SRCNAM-$VERSION
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. export CFLAGS=$SLKCFLAGS
  73. export CXXFLAGS="$SLKCFLAGS -std=c++11"
  74. ./configure \
  75. --with-wwwbrowser=firefox \
  76. --with-helpurl="/usr/doc/$PRGNAM-$VERSION/docs" \
  77. --with-protobaseurl="/usr/doc/$PRGNAM-$VERSION/docs"
  78. make
  79. install -c -d $PKG/install $PKG/usr/bin $PKG/usr/man/man1
  80. cp -a bin/* /$PKG/usr/bin
  81. cp -a tools/run_dune_and_aqsis.sh /$PKG/usr/bin
  82. install -c -m 644 ./man/dune.1 /$PKG/usr/man/man1
  83. install -c -d $PKG/usr/doc/$PRGNAM-$VERSION
  84. cp -fr docs $PKG/usr/doc/$PRGNAM-$VERSION
  85. install -D -m 0644 desktop/kde/dune.desktop \
  86. $PKG/usr/share/applications/dune.desktop
  87. install -D -m 0644 desktop/kde/dune.png \
  88. $PKG/usr/share/pixmaps/dune.png
  89. install -D -m 644 -p include/white_dune/libC++RWD_namespace.h \
  90. $PKG/usr/include/white_dune/libC++RWD_namespace.h
  91. install -D -m 644 -p include/white_dune/libC++RWD.h \
  92. $PKG/usr/include/white_dune/libC++RWD.h
  93. install -D -m 644 -p include/white_dune/libCRWD.h \
  94. $PKG/usr/include/white_dune/libCRWD.h
  95. find $PKG/usr/man -type f -exec gzip -9 {} \;
  96. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  97. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  98. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  99. mkdir -p $PKG/install
  100. cat $CWD/slack-desc > $PKG/install/slack-desc
  101. cd $PKG
  102. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE