unpaper.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. #!/bin/bash
  2. # Slackware build script for unpaper
  3. # Copyright 2008-2014 LukenShiro, Italy
  4. # Copyright 2019 Logan Rathbone <poprocks@gmail.com>
  5. #
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. #
  25. # CHANGELOG
  26. #
  27. # 20191107 Logan Rathbone <poprocks@gmail.com> 6.1-1
  28. # - Update to 6.1
  29. # - Add ffmpeg as new dependency.
  30. # - As of time of writing, works against ffmpeg3 and 4 (as shipped
  31. # with current). Don't try to build against ffmpeg4 from SBO
  32. # presently, as it places pkgconfig files in the 'ffmpeg4' sub-
  33. # dir.
  34. # - The ffmpeg dep can be removed once 15.0 ships, as it will be
  35. # shipped wth the distro.
  36. cd $(dirname $0) ; CWD=$(pwd)
  37. PRGNAM=unpaper
  38. VERSION=${VERSION:-6.1}
  39. BUILD=${BUILD:-1}
  40. TAG=${TAG:-_SBo}
  41. PKGTYPE=${PKGTYPE:-tgz}
  42. if [ -z "$ARCH" ]; then
  43. case "$( uname -m )" in
  44. i?86) ARCH=i486 ;;
  45. arm*) ARCH=arm ;;
  46. *) ARCH=$( uname -m ) ;;
  47. esac
  48. fi
  49. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  50. # the name of the created package would be, and then exit. This information
  51. # could be useful to other scripts.
  52. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  53. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  54. exit 0
  55. fi
  56. TMP=${TMP:-/tmp/SBo}
  57. PKG=$TMP/package-$PRGNAM
  58. OUTPUT=${OUTPUT:-/tmp}
  59. if [ "$ARCH" = "i486" ]; then
  60. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  61. elif [ "$ARCH" = "i686" ]; then
  62. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  63. elif [ "$ARCH" = "x86_64" ]; then
  64. SLKCFLAGS="-O2 -fPIC"
  65. fi
  66. set -e
  67. rm -rf $PKG
  68. mkdir -p $TMP $PKG $OUTPUT
  69. cd $TMP
  70. rm -rf $PRGNAM-$VERSION
  71. tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
  72. cd $PRGNAM-$VERSION
  73. chown -R root:root .
  74. find -L . \
  75. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  76. -exec chmod 755 {} \; -o \
  77. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  78. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  79. CFLAGS="$SLKCFLAGS" \
  80. CXXFLAGS="$SLKCFLAGS" \
  81. ./configure \
  82. --prefix=/usr \
  83. --mandir=/usr/man \
  84. --docdir=/usr/doc/$PRGNAM-$VERSION \
  85. --build=$ARCH-slackware-linux
  86. make
  87. make install DESTDIR=$PKG
  88. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  89. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  90. find $PKG/usr/man -type f -exec gzip -9 {} \;
  91. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  92. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
  93. cp AUTHORS COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION/
  94. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  95. mkdir -p $PKG/install
  96. cat $CWD/slack-desc > $PKG/install/slack-desc
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE