gpaint.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. #!/bin/bash
  2. # Slackware build script for gpaint
  3. # Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=gpaint
  24. VERSION=${VERSION:-0.3.3}
  25. BUILD=${BUILD:-2}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-2-$VERSION
  63. tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
  64. cd $PRGNAM-2-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. # Thanks to Debian for the patches! And the man page and icon! And the
  72. # whole source tarball, actually...
  73. patch -p1 -i $CWD/patches/01_drawing.patch
  74. patch -p1 -i $CWD/patches/02_remove_menu_h_reference.patch
  75. patch -p1 -i $CWD/patches/09_fix_menu_entry.patch
  76. patch -p1 -i $CWD/patches/10_fix_crash_on_font_select.patch
  77. patch -p1 -i $CWD/patches/11_fix_image_rotation.patch
  78. patch -p1 -i $CWD/patches/20_fix_line_width_combo.patch
  79. patch -p1 -i $CWD/patches/21_fix_crash_on_fill_button_click.patch
  80. patch -p1 -i $CWD/patches/22_fix_not_printable_string.patch
  81. patch -p1 -i $CWD/patches/23_add_accelerator_keys.patch
  82. patch -p1 -i $CWD/patches/24_fix_crash_on_failed_write.patch
  83. patch -p1 -i $CWD/patches/25_fix_color_selection.patch
  84. patch -p1 -i $CWD/patches/26_fix_toolbar.patch
  85. LIBS="-lm" \
  86. CFLAGS="$SLKCFLAGS" \
  87. CXXFLAGS="$SLKCFLAGS" \
  88. ./configure \
  89. --prefix=/usr \
  90. --libdir=/usr/lib${LIBDIRSUFFIX} \
  91. --sysconfdir=/etc \
  92. --localstatedir=/var \
  93. --mandir=/usr/man \
  94. --build=$ARCH-slackware-linux
  95. make
  96. make install DESTDIR=$PKG
  97. install -D -m644 $CWD/$PRGNAM.1 $PKG/usr/man/man1/$PRGNAM.1
  98. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  99. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  100. find $PKG/usr/man -type f -exec gzip -9 {} \;
  101. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  103. cp -a \
  104. AUTHORS ChangeLog COPYING INSTALL NEWS README THANKS TODO \
  105. $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. # Menu item and icon
  108. mkdir -p $PKG/usr/share/{applications,pixmaps}
  109. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  110. cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
  111. mkdir -p $PKG/install
  112. cat $CWD/slack-desc > $PKG/install/slack-desc
  113. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  114. cd $PKG
  115. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE