saga-gis.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. #!/bin/bash
  2. # Slackware build script for saga-gis
  3. # Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220301 bkw: Modified by SlackBuilds.org: fix wxPython/wxGTK3 conflict.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=saga-gis
  25. VERSION=${VERSION:-7.9.0}
  26. BUILD=${BUILD:-2}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. SRCNAM=saga
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  38. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  39. exit 0
  40. fi
  41. TMP=${TMP:-/tmp/SBo}
  42. PKG=$TMP/package-$SRCNAM
  43. OUTPUT=${OUTPUT:-/tmp}
  44. # issues with -O2 causing build failures
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS=""
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $SRCNAM-$VERSION
  63. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  64. cd $SRCNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  71. if [ "$OPENCV" != "ON" ] ; then
  72. sed -i "s/CVFOUND=1/true/g" configure
  73. fi
  74. sed -i "s/isinf/std::isinf/g" src/saga_core/saga_gui/wksp_map_layer.cpp
  75. # 20220308 bkw: no configure option or environment variable for the
  76. # wx config script to use, so force it this way:
  77. mkdir -p wxtmp
  78. ln -s /usr/lib$LIBDIRSUFFIX/wx/config/gtk3-unicode-3.0 wxtmp/wx-config
  79. export PATH=$(pwd)/wxtmp:$PATH
  80. CFLAGS="$SLKCFLAGS" \
  81. CXXFLAGS="$SLKCFLAGS" \
  82. PYTHON=python3 \
  83. ./configure \
  84. --build=$ARCH \
  85. --prefix=/usr \
  86. --libdir=/usr/lib${LIBDIRSUFFIX} \
  87. --mandir=/usr/man \
  88. --enable-python \
  89. --disable-odbc \
  90. --build=$ARCH-slackware-linux
  91. make
  92. make install DESTDIR=$PKG
  93. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  94. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  95. find $PKG/usr/man -type f -exec gzip -9 {} \;
  96. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  97. mv $PKG/usr/share/metainfo $PKG/usr/share/appdata
  98. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  99. cp -a \
  100. AUTHORS COPYING ChangeLog NEWS README \
  101. $PKG/usr/doc/$PRGNAM-$VERSION
  102. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  103. rm -f $PKG/usr/lib*/*.la
  104. mkdir -p $PKG/install
  105. cat $CWD/slack-desc > $PKG/install/slack-desc
  106. cd $PKG
  107. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE