p4v.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. #!/bin/bash
  2. # Slackware build script for p4v
  3. # Copyright 2009 Raymond Bailey <GooseYArd@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Modified by the SlackBuilds.org --michiel
  23. #
  24. # Change History
  25. # ==========
  26. # Mon Aug 30 11:39:47 EDT 2010: add version discovery (rab)
  27. #
  28. cd $(dirname $0) ; CWD=$(pwd)
  29. PRGNAM=p4v
  30. VERSION=${VERSION:-2017.2.1573260}
  31. BUILD=${BUILD:-1}
  32. TAG=${TAG:-_SBo}
  33. PKGTYPE=${PKGTYPE:-tgz}
  34. set -e
  35. ###sbolint off (because VERSION is being redefined)
  36. LOCALVER=`tar tf p4v.tgz 2> /dev/null | head -1 | cut -d- -f 2 | cut -d/ -f1`
  37. VERSION=${LOCALVER:-$VERSION}
  38. ###sbolint on
  39. if [ -z "$ARCH" ]; then
  40. case "$( uname -m )" in
  41. i?86) ARCH=i586 ;;
  42. arm*) ARCH=arm ;;
  43. *) ARCH=$( uname -m ) ;;
  44. esac
  45. fi
  46. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  47. # the name of the created package would be, and then exit. This information
  48. # could be useful to other scripts.
  49. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  50. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  51. exit 0
  52. fi
  53. TMP=${TMP:-/tmp/SBo}
  54. PKG=$TMP/package-$PRGNAM
  55. OUTPUT=${OUTPUT:-/tmp}
  56. if [ "$ARCH" = "i586" ]; then
  57. LIBDIRSUFFIX=""
  58. elif [ "$ARCH" = "i686" ]; then
  59. LIBDIRSUFFIX=""
  60. elif [ "$ARCH" = "x86_64" ]; then
  61. LIBDIRSUFFIX="64"
  62. else
  63. LIBDIRSUFFIX=""
  64. fi
  65. set -e
  66. rm -rf $PKG
  67. mkdir -p $TMP $PKG $OUTPUT
  68. cd $TMP
  69. rm -rf $PRGNAM-$VERSION
  70. tar xvf $CWD/$PRGNAM.tgz
  71. cd $PRGNAM-$VERSION
  72. chown -R root:root .
  73. find -L . \
  74. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  75. -o -perm 511 \) -exec chmod 755 {} \; -o \
  76. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  77. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  78. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
  79. # It would be a bad idea to copy p4v's qt.conf into /usr/bin
  80. rm bin/qt.conf
  81. cp -a bin $PKG/usr/bin
  82. mv lib/p4v $PKG/usr/lib${LIBDIRSUFFIX}/p4v
  83. mv lib/icu $PKG/usr/lib${LIBDIRSUFFIX}/p4v/icu
  84. # Adapt the path for lib/lib64
  85. sed -i "s%prefix/lib/%prefix/lib${LIBDIRSUFFIX}/%g" $PKG/usr/bin/$PRGNAM
  86. # ICU library path
  87. sed -i "s%lib${LIBDIRSUFFIX}/icu%lib${LIBDIRSUFFIX}/p4v/icu%g" $PKG/usr/bin/$PRGNAM
  88. # Add Qt plugin path through environment variable since we can't use qt.conf
  89. sed -i "s%export P4VRES%export P4VRES QT_PLUGIN_PATH=\$QT5DIR/plugins%g" $PKG/usr/bin/$PRGNAM
  90. # Copy to the other wrappers
  91. cp $PKG/usr/bin/$PRGNAM $PKG/usr/bin/p4merge
  92. cp $PKG/usr/bin/$PRGNAM $PKG/usr/bin/p4admin
  93. cp $PKG/usr/bin/$PRGNAM $PKG/usr/bin/p4vc
  94. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  95. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  96. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. mkdir -p $PKG/usr/share/applications
  99. for PRG in $PRGNAM p4admin p4merge; do
  100. cat $CWD/$PRG.desktop > $PKG/usr/share/applications/$PRG.desktop
  101. done
  102. mkdir -p $PKG/usr/share/icons/hicolor/{16x16,32x32,48x48,96x96}/apps
  103. for PRG in P4-V P4-Admin P4-Merge; do
  104. for SIZE in 16x16 32x32 48x48 96x96; do
  105. ln -s ../../../../../lib${LIBDIRSUFFIX}/p4v/P4VResources/icons/${PRG}_${SIZE}.png \
  106. $PKG/usr/share/icons/hicolor/$SIZE/apps/${PRG}.png
  107. done
  108. done
  109. mkdir -p $PKG/install
  110. cat $CWD/slack-desc > $PKG/install/slack-desc
  111. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  112. cd $PKG
  113. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE