nexus.SlackBuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. #!/bin/bash
  2. # Slackware build script for Sonatype Nexus Repository OSS
  3. # Copyright 2019 Giorgio Peron <giorgio.peron@gmail.com>, Belluno, Italy
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=nexus
  24. VERSION=${VERSION:-3.15.2_01}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCVERSION=$(echo $VERSION | tr _ -)
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "x86_64" ]; then
  51. LIBDIRSUFFIX="64"
  52. else
  53. LIBDIRSUFFIX=""
  54. fi
  55. set -e
  56. # Check if the 'nexus' user & group exist:
  57. if [ "$(grep ^nexus /etc/passwd)" = "" -o "$(grep ^nexus /etc/group)" = "" ] ; then
  58. printf "\nYou must have a nexus user and group.\n\nExample:\n"
  59. printf "\t# groupadd -g 252 nexus\n"
  60. printf "\t# useradd -u 252 -d /dev/null -s /bin/sh -g nexus nexus\n\n"
  61. exit 1
  62. fi
  63. rm -rf $PKG
  64. mkdir -p $TMP $PKG $OUTPUT
  65. cd $TMP
  66. rm -rf $PRGNAM-$SRCVERSION
  67. rm -rf sonatype-work
  68. tar xvf $CWD/$PRGNAM-$SRCVERSION-unix.tar.gz
  69. cd $PRGNAM-$SRCVERSION
  70. chown -R root:root .
  71. find -L . \
  72. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  73. -o -perm 511 \) -exec chmod 755 {} \; -o \
  74. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  75. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  76. mkdir -p $PKG/usr/share/$PRGNAM
  77. mkdir -p $PKG/etc/rc.d
  78. mkdir -p $PKG/var/{lib,log,tmp}/$PRGNAM
  79. mv * $PKG/usr/share/$PRGNAM
  80. mv .install4j $PKG/usr/share/$PRGNAM
  81. cd $PKG/etc
  82. ln -sf ../usr/share/$PRGNAM/etc $PRGNAM
  83. cd $PKG/usr/share/$PRGNAM
  84. ln -sf ../../../var/lib/$PRGNAM data
  85. cd $PKG/var/lib/$PRGNAM
  86. ln -sf ../../log/$PRGNAM log
  87. ln -sf ../../tmp/$PRGNAM tmp
  88. cd $TMP
  89. cp sonatype-work/nexus3/log/.placeholder $PKG/var/log/$PRGNAM
  90. cp sonatype-work/nexus3/tmp/.placeholder $PKG/var/tmp/$PRGNAM
  91. cp -r sonatype-work/nexus3/orient $PKG/var/lib/$PRGNAM
  92. cp sonatype-work/nexus3/clean_cache $PKG/var/lib/$PRGNAM
  93. # Fix configuration files
  94. sed -i $PKG/usr/share/$PRGNAM/bin/$PRGNAM.rc \
  95. -e "s:#run_as_user=\"\":run_as_user=\"nexus\":g"
  96. sed -i $PKG/usr/share/$PRGNAM/bin/$PRGNAM \
  97. -e "s:# INSTALL4J_JAVA_HOME_OVERRIDE=:INSTALL4J_JAVA_HOME_OVERRIDE=\"/usr/lib${LIBDIRSUFFIX}/java\":g"
  98. sed -i $PKG/usr/share/$PRGNAM/bin/$PRGNAM.vmoptions \
  99. -e "s\-XX:LogFile=../sonatype-work/nexus3/log/jvm.log\-XX:LogFile=/var/lib/nexus/log/jvm.log\g" \
  100. -e "s:-Dkaraf.data=../sonatype-work/nexus3:-Dkaraf.data=/var/lib/nexus:g" \
  101. -e "s:-Djava.io.tmpdir=../sonatype-work/nexus3/tmp:-Djava.io.tmpdir=/var/lib/nexus/tmp:g"
  102. sed -i $PKG/usr/share/$PRGNAM/.install4j/i4jparams.conf \
  103. -e "s:<variable name=\"nexus.dataDir\" value=\"../sonatype-work/nexus3\" />:<variable name=\"nexus.dataDir\" value=\"/var/lib/nexus\" />:g"
  104. cd $PKG/etc/rc.d
  105. ln -sf ../../usr/share/$PRGNAM/bin/$PRGNAM rc.$PRGNAM
  106. cd $PKG
  107. # Fix ownership of some dirs
  108. chown -R nexus:nexus $PKG/var/{lib,log,tmp}/$PRGNAM
  109. chown -R nexus:nexus $PKG/usr/share/$PRGNAM/etc
  110. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  111. mv $PKG/usr/share/$PRGNAM/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
  112. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  113. mkdir -p $PKG/install
  114. cat $CWD/slack-desc > $PKG/install/slack-desc
  115. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  116. cd $PKG
  117. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE