1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495 |
- #!/bin/bash
- # Slackware build script for netbeans
- # Copyright 2018-2019 Sukma Wardana <sukma.wardana@mail.com>
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=netbeans
- VERSION=${VERSION:-13}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- ARCH=noarch
- PKGNAM=netbeans-${VERSION}-bin.zip
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=${TMP}/package-${PRGNAM}
- OUTPUT=${OUTPUT:-/tmp}
- set -e
- rm -rf ${PKG}
- mkdir -p ${TMP} ${PKG}/opt ${OUTPUT}
- cd ${PKG}/opt
- unzip -o ${CWD}/${PKGNAM}
- cd ${PRGNAM}
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- install -D -m 644 ${CWD}/${PRGNAM}.desktop \
- ${PKG}/usr/share/applications/${PRGNAM}.desktop
- install -D -m 644 ${CWD}/${PRGNAM}.png ${PKG}/usr/share/pixmaps/${PRGNAM}.png
- install -D -m 755 ${CWD}/${PRGNAM}.sh ${PKG}/usr/bin/${PRGNAM}
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- mv $PKG/opt/$PRGNAM/etc/netbeans.conf \
- $PKG/opt/$PRGNAM/etc/netbeans.conf.new
- mv $PKG/opt/$PRGNAM/etc/netbeans.clusters \
- $PKG/opt/$PRGNAM/etc/netbeans.clusters.new
- mv $PKG/opt/$PRGNAM/etc/netbeans.import \
- $PKG/opt/$PRGNAM/etc/netbeans.import.new
- mkdir -p ${PKG}/usr/doc/${PRGNAM}-${VERSION}
- cp -a \
- DEPENDENCIES LICENSE NOTICE README.html \
- ${PKG}/usr/doc/${PRGNAM}-${VERSION}
- cat ${CWD}/${PRGNAM}.SlackBuild > \
- ${PKG}/usr/doc/${PRGNAM}-${VERSION}/${PRGNAM}.SlackBuild
- mkdir -p ${PKG}/install
- cat ${CWD}/slack-desc > ${PKG}/install/slack-desc
- cat ${CWD}/doinst.sh > ${PKG}/install/doinst.sh
- cd ${PKG}
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|