lua53.SlackBuild 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. #!/bin/bash
  2. # Slackware build script for lua53
  3. # Copyright 2018 Azure Zanculmarktum <zanculmarktum@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Some of the codes were taken from development/lua/lua.SlackBuild
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=lua53
  25. SRCNAM=${PRGNAM%??}
  26. VERSION=${VERSION:-5.3.4}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $SRCNAM-$VERSION
  65. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  66. cd $SRCNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. eval $(sed -ne '/^\(V\|R\)= /s, ,,p' Makefile)
  74. sed -i \
  75. -e '/^INSTALL_TOP= /s,\(/usr\).*,\$(DESTDIR)\1,' \
  76. -e '/^INSTALL_INC= /s,include,&/lua\$V,' \
  77. -e '/^INSTALL_LIB= /s,lib,&'"${LIBDIRSUFFIX}"',' \
  78. -e '/^INSTALL_CMOD= /s,lib,&'"${LIBDIRSUFFIX}"',' \
  79. -e '/^TO_BIN= /s,luac\?,&\$V,g' \
  80. -e '/^TO_LIB= /s,liblua,&\$V,' \
  81. Makefile
  82. sed -i \
  83. -e '/^CFLAGS= /s,-O2,'"$SLKCFLAGS"',' \
  84. -e '/-DLUA_USE_LINUX.*-Wl,-E -ldl -lreadline/s|-lreadline|& -lncurses|' \
  85. -e '/^LUA_A=/s,liblua,&'"$V"',' \
  86. -e '/^LUA_T=/s,lua,&'"$V"',' \
  87. -e '/^LUAC_T=/s,luac,&'"$V"',' \
  88. src/Makefile
  89. sed -i \
  90. -e '/^#define LUA_ROOT/s,".*,"/usr/",' \
  91. -e '/^#define LUA_CDIR/s,"lib,&'"${LIBDIRSUFFIX}"',' \
  92. src/luaconf.h
  93. make linux
  94. make install DESTDIR=$PKG
  95. # Now let's build the shared library
  96. mkdir -p shared
  97. cd shared
  98. ar -x $PKG/usr/lib${LIBDIRSUFFIX}/liblua$V.a
  99. gcc -ldl -lreadline -lncurses -lm -shared *.o -o liblua$V.so.$R
  100. cp -a liblua$V.so.$R $PKG/usr/lib${LIBDIRSUFFIX}
  101. ( cd $PKG/usr/lib${LIBDIRSUFFIX}
  102. ln -s liblua$V.so.$R liblua$V.so.$V
  103. ln -s liblua$V.so.$R liblua$V.so.${V%??}
  104. ln -s liblua$V.so.$R liblua$V.so
  105. )
  106. cd - >/dev/null
  107. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
  108. cd $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
  109. sed \
  110. -e '/^V= /s, .*, '"$V"',' \
  111. -e '/^R= /s, .*, '"$R"',' \
  112. -e '/^prefix= /s,\(/usr\).*,\1,' \
  113. -e '/^INSTALL_INC= /s,include,&/lua\${V},' \
  114. -e '/^INSTALL_LIB= /s,lib,&'"${LIBDIRSUFFIX}"',' \
  115. -e '/^INSTALL_CMOD= /s,lib,&'"${LIBDIRSUFFIX}"',' \
  116. -e '/^libdir=/s,/lib,&'"${LIBDIRSUFFIX}"',' \
  117. -e '/^includedir=/s,/include,&/lua\${V},' \
  118. $CWD/lua.pc.in > lua$V.pc
  119. ln -s lua$V.pc lua-$V.pc
  120. ln -s lua$V.pc lua${V%.?}${V#?.}.pc
  121. cd - >/dev/null
  122. cd $PKG/usr/man/man1
  123. mv lua.1 lua$V.1
  124. mv luac.1 luac$V.1
  125. cd - >/dev/null
  126. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  127. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  128. find $PKG/usr/man -type f -exec gzip -9 {} \;
  129. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  130. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  131. cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
  132. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  133. mkdir -p $PKG/install
  134. cat $CWD/slack-desc > $PKG/install/slack-desc
  135. cd $PKG
  136. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE