123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990 |
- #!/bin/bash
- # Slackware build script for liquibase
- # Copyright (c) 2017 Alan Alberghini <414N@slacky.it>
- # All rights reserved.
- #
- # Permission to use, copy, modify, and distribute this software for
- # any purpose with or without fee is hereby granted, provided that
- # the above copyright notice and this permission notice appear in all
- # copies.
- #
- # THIS SOFTWARE IS PROVIDED AS IS'' AND ANY EXPRESSED OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
- # IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
- # CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
- # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
- # USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
- # ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
- # OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
- # OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- # SUCH DAMAGE.
- # -----------------------------------------------------------------------------
- #
- # Build history:
- #
- # 1 - Initial release.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=liquibase
- VERSION=${VERSION:-3.5.3}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- ARCH=noarch
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- DOCS="README.txt LICENSE.txt"
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- DESTDIR=$PKG/opt/$PRGNAM
- mkdir -p $DESTDIR
- cd $DESTDIR
- tar xvf $CWD/${PRGNAM}-${VERSION}-bin.tar.gz
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- find . -type f -name \*.bat -delete
- mkdir -p $PKG/etc/profile.d
- install -m0755 $CWD/profile.d/* $PKG/etc/profile.d
- mkdir -p $PKG/usr/bin
- ln -sf /opt/$PRGNAM/$PRGNAM $PKG/usr/bin/$PRGNAM
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
- ln -sf /opt/$PRGNAM/sdk $PKG/usr/doc/$PRGNAM-$VERSION/
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|