jbake.SlackBuild 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. #!/bin/bash
  2. #!/bin/sh
  3. # Slackware build script for jbake
  4. # Copyright 2019 Sukma Wardana
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=jbake
  25. VERSION=${VERSION:-2.6.3}
  26. BUILD=${BUILD:-1}
  27. ARCH=noarch
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. PKGNAM=jbake-${VERSION}-bin.zip
  31. JBAKE_HOME=/usr/share/jbake
  32. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  33. # the name of the created package would be, and then exit. This information
  34. # could be useful to other scripts.
  35. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  36. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  37. exit 0
  38. fi
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=${TMP}/package-${PRGNAM}
  41. OUTPUT=${OUTPUT:-/tmp}
  42. set -e
  43. rm -rf ${PKG}
  44. mkdir -p ${TMP} ${OUTPUT} ${PKG}/${JBAKE_HOME} \
  45. ${PKG}/usr/{bin,share/java}
  46. cd ${TMP}
  47. rm -rf ${PRGNAM}-${VERSION}
  48. unzip -o ${CWD}/${PKGNAM}
  49. mv ${PRGNAM}-${VERSION}-bin ${PRGNAM}-${VERSION}
  50. cd ${PRGNAM}-${VERSION}
  51. chown -R root:root .
  52. find -L . \
  53. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  54. -o -perm 511 \) -exec chmod 755 {} \; -o \
  55. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  56. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  57. cp -a bin lib ${PKG}/${JBAKE_HOME}
  58. # Remove windows shell scripts
  59. rm -rf ${PKG}/${JBAKE_HOME}/bin/*.bat
  60. cd ${PKG}/usr/bin
  61. ln -s ${JBAKE_HOME}/bin/jbake
  62. # Switch back to previous directory.
  63. cd -
  64. cd ${PKG}/usr/share/java
  65. for jar in ${PKG}/${JBAKE_HOME}/lib/*.jar ; do
  66. ln -s ${JBAKE_HOME}/lib/$(basename ${jar}) $(basename ${jar})
  67. done
  68. # Copy JBake logging configuration.
  69. mkdir logging
  70. ln -s ${JBAKE_HOME}/lib/logging/* logging/
  71. cd -
  72. mkdir -p ${PKG}/etc/profile.d
  73. for script in $(ls "${CWD}/profile.d/${PRGNAM}"*) ; do
  74. cp ${script} ${PKG}/etc/profile.d/$(basename ${script})
  75. chmod 755 ${PKG}/etc/profile.d/*
  76. done
  77. mkdir -p ${PKG}/usr/doc/${PRGNAM}-${VERSION}
  78. cat ${CWD}/${PRGNAM}.SlackBuild > \
  79. ${PKG}/usr/doc/${PRGNAM}-${VERSION}/${PRGNAM}.SlackBuild
  80. cat ${CWD}/README > ${PKG}/usr/doc/${PRGNAM}-${VERSION}/README.SBo
  81. mkdir -p ${PKG}/install
  82. cat ${CWD}/slack-desc > ${PKG}/install/slack-desc
  83. cd ${PKG}
  84. /sbin/makepkg -l y -c n ${OUTPUT}/${PRGNAM}-${VERSION}-${ARCH}-${BUILD}${TAG}.$PKGTYPE