gambas3.SlackBuild 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129
  1. #!/bin/bash
  2. # Slackware build script for Gambas 3
  3. # updates since version 3.11.2 Copyright 2018-2023 Tim Dickson dickson.tim@googlemail.com
  4. # Copyright 2012-2015 Fridrich von Stauffenberg <cancellor2@gmail.com>
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=gambas3
  25. SRCNAM=gambas
  26. VERSION=${VERSION:-3.18.1}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. #check updated for slackware 15 for new package location
  62. if [ "x`ls -H /var/lib/pkgtools/packages|grep ^$PRGNAM|wc -l`" = "x1" ]; then
  63. #current installs of gambas should be uninstalled before
  64. #attempting to create this gambas3 package
  65. echo "you must uninstall $PRGNAM before creating package $PRGNAM ver $VERSION"
  66. exit 2
  67. fi
  68. rm -rf $PKG
  69. mkdir -p $TMP $PKG $OUTPUT
  70. cd $TMP
  71. rm -rf $SRCNAM-$VERSION
  72. tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
  73. cd $SRCNAM-$VERSION
  74. chown -R root:root .
  75. ./reconf-all
  76. CFLAGS="$SLKCFLAGS" \
  77. CXXFLAGS="$SLKCFLAGS" \
  78. LLVM_CONFIG=llvm-config \
  79. ./configure \
  80. --prefix=/usr \
  81. --libdir=/usr/lib${LIBDIRSUFFIX} \
  82. --build=$ARCH-slackware-linux \
  83. $qt5
  84. make
  85. make -j1 install DESTDIR=$PKG XDG_UTILS=""
  86. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  87. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  88. mv $PKG/usr/share/man $PKG/usr
  89. find $PKG/usr/man -type f -exec gzip -9 {} \;
  90. mkdir -p $PKG/usr/share/icons/hicolor/{scalable/apps,48x48/apps,64x64/mimetypes}
  91. cp -a app/desktop/$PRGNAM.svg $PKG/usr/share/icons/hicolor/scalable/apps
  92. convert -resize 48x48 app/desktop/$PRGNAM.png $PKG/usr/share/icons/hicolor/48x48/apps/$PRGNAM.png
  93. convert -resize 64x64 app/mime/application-x-${SRCNAM}script.png $PKG/usr/share/icons/hicolor/64x64/mimetypes/script.png
  94. convert -resize 64x64 app/mime/application-x-${SRCNAM}serverpage.png $PKG/usr/share/icons/hicolor/64x64/mimetypes/serverpage.png
  95. convert -resize 64x64 main/mime/application-x-$PRGNAM.png $PKG/usr/share/icons/hicolor/64x64/mimetypes/application-x-$PRGNAM.png
  96. mkdir -p $PKG/usr/share/{applications,mime/packages}
  97. cp -a app/desktop/$PRGNAM.desktop $PKG/usr/share/applications
  98. chmod 644 $PKG/usr/share/applications/$PRGNAM.desktop
  99. cp -a app/mime/application-x-${SRCNAM}{script,serverpage}.xml \
  100. $PKG/usr/share/mime/packages
  101. chmod -x $PKG/usr/share/appdata/$PRGNAM.appdata.xml
  102. cp -a main/mime/application-x-$PRGNAM.xml $PKG/usr/share/mime/packages
  103. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  104. #ChangeLog is empty so miss out for now
  105. cp -a COPYING README TODO $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE