123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110 |
- #!/bin/bash
- ## Copyright (C) 2016 Ryan S. Northrup <northrup@yellowapple.us>
- ## Permission is hereby granted, free of charge, to any person
- ## obtaining a copy of this software and associated documentation
- ## files (the "Software"), to deal in the Software without
- ## restriction, including without limitation the rights to use, copy,
- ## modify, merge, publish, distribute, sublicense, and/or sell copies
- ## of the Software, and to permit persons to whom the Software is
- ## furnished to do so, subject to the following conditions:
- ## The above copyright notice and this permission notice shall be
- ## included in all copies or substantial portions of the Software.
- ## THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
- ## EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
- ## MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
- ## NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
- ## BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
- ## ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
- ## CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
- ## SOFTWARE.
- ## Based on erlang-otp.SlackBuild, which was written by halflife
- ## (vzdorovenco@yahoo.com). Please **DO NOT** email halflife about
- ## this SlackBuild.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=elixir
- VERSION=${VERSION:-1.11.3}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- SRC_NAME_VERSION=elixir-${VERSION}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=${PKG:-$TMP/package-$PRGNAM}
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
- else
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRC_NAME_VERSION
- tar xvf $CWD/$SRC_NAME_VERSION.tar.gz
- cd $SRC_NAME_VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- make
- make DESTDIR=$PKG PREFIX=/usr LIBDIR=lib${LIBDIRSUFFIX} install
- cd $PKG/usr/bin
- for file in elixir elixirc iex mix ; do
- rm -f $file
- ln -s ../lib${LIBDIRSUFFIX}/elixir/bin/$file .
- done
- cd -
- chown -R root:root $PKG/usr/lib${LIBDIRSUFFIX}/elixir
- chmod -R u+w,go+r-w,a-s $PKG/usr/lib${LIBDIRSUFFIX}/elixir
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- for file in CHANGELOG.md CODE_OF_CONDUCT.md LICENSE \
- NOTICE README.md RELEASE.md SECURITY.md VERSION ; do
- cp $file $PKG/usr/doc/$PRGNAM-$VERSION
- done
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mv $PKG/usr/share/man $PKG/usr/man
- rmdir $PKG/usr/share
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|