cf-cli.SlackBuild 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. #!/bin/bash
  2. # Slackware build script for cf-cli
  3. # Copyright 2020 Dmitrii Sosedov, United States
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=cf-cli
  24. BIN=cf
  25. VERSION=${VERSION:-7.1.0}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. x86_64) ARCH=x86_64 ;;
  32. *) ARCH=i686 ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i686" ]; then
  46. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. mv $CWD/${BIN}7-cli\_$VERSION\_linux\_$ARCH.tgz $CWD/$PRGNAM\_$VERSION\_linux\_$ARCH.tgz
  49. elif [ "$ARCH" = "x86_64" ]; then
  50. SLKCFLAGS="-O2 -fPIC"
  51. LIBDIRSUFFIX="64"
  52. mv $CWD/${BIN}7-cli\_$VERSION\_linux\_x86-64.tgz $CWD/$PRGNAM\_$VERSION\_linux\_$ARCH.tgz
  53. else
  54. echo "$ARCH is unsupported."
  55. exit 1
  56. fi
  57. set -e
  58. rm -rf $PKG
  59. mkdir -p $TMP $PKG $PKG/usr/{bin,doc} $OUTPUT
  60. cd $TMP
  61. rm -rf $PRGNAM-$VERSION
  62. mkdir -p $PRGNAM-$VERSION/bin
  63. tar xvf $CWD/$PRGNAM\_$VERSION\_linux\_$ARCH.tgz -C $PRGNAM-$VERSION
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. mv ${BIN}7 $PKG/usr/bin/.
  72. mv $BIN $PKG/usr/bin/.
  73. find -L $PKG -type d -exec chmod 755 {} \;
  74. chmod 755 $PKG/usr/bin/${BIN}7
  75. chmod 755 $PKG/usr/bin/$BIN
  76. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  77. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  78. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  79. mv LICENSE $PKG/usr/doc/$PRGNAM-$VERSION/.
  80. mv NOTICE $PKG/usr/doc/$PRGNAM-$VERSION/.
  81. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  82. cat $CWD/$PRGNAM.info > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.info
  83. mkdir -p $PKG/install
  84. cat $CWD/slack-desc > $PKG/install/slack-desc
  85. cd $PKG
  86. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE