123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122 |
- #!/bin/bash
- # Slackware build script for bigloo
- # Originally by Jockey S. Kyd (jockey dot kyd at gmail dot com)
- # Modified by Ryan P.C. McQuen, WA, ryanpcmcquen@member.fsf.org
- # This program is free software; you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
- # the Free Software Foundation; either version 2 of the License, or
- # (at your option) any later version, with the following exception:
- # the text of the GPL license may be omitted..
- # This program is distributed in the hope that it will be useful, but
- # without any warranty; without even the implied warranty of
- # merchantability or fitness for a particular purpose. Compiling,
- # interpreting, executing or merely reading the text of the program
- # may result in lapses of consciousness and/or very being, up to and
- # including the end of all existence and the Universe as we know it.
- # See the GNU General Public License for more details.
- # You may have received a copy of the GNU General Public License
- # along with this program (most likely, a file named COPYING). If
- # not, see <http://www.gnu.org/licenses/>.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=bigloo
- VERSION=${VERSION:-4.3f}
- SRCVER=$(echo $VERSION | tr _ -)
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$(uname -m)" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$(uname -m) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM$SRCVER
- tar xvf $CWD/$PRGNAM$SRCVER.tar.gz
- cd $PRGNAM$SRCVER
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # fix canonical system name detected during configuration
- # e.g. x86_64-unknown-linux-gnu -> x86_64-slackware-linux-gnu
- sed -ri '/^(build|host)=/ s/`$/ | sed "s:-unknown-:-slackware-:"` /' \
- autoconf/gcconfigureopt
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --libdir=/usr/lib$LIBDIRSUFFIX \
- --mandir=/usr/man/man1 \
- --infodir=/usr/info \
- --sharedcompiler=yes \
- --sharedbde=yes
- make
- make install DESTDIR=$PKG
- find $PKG -print0 | xargs -0 file \
- | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
- || true
- rm -f $PKG/usr/info/dir
- find $PKG/usr/info -type f -exec gzip -9 {} \;
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp COPYING ChangeLog INSTALL.jvm LICENSE \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|