123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143 |
- #!/bin/bash
- # Slackware build script for avr-gcc
- # Written by Marek Buras <cyfr0n (at) go2 !dot pl>
- # Now maintained by thorsten <thorsten (dot) johannvorderbrueggen (at) t-online (dot) de>
- # This file is placed in the public domain.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=avr-gcc
- VERSION=${VERSION:-10.2.0}
- ISLVERSION=${ISLVERSION:-0.22}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -pipe"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -pipe"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP/$PRGNAM $PKG $OUTPUT
- cd $TMP/$PRGNAM
- rm -rf $TMP/$PRGNAM/*
- tar xvf $CWD/gcc-$VERSION.tar.xz
- tar xvf $CWD/isl-$ISLVERSION.tar.bz2
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- cd gcc-$VERSION
- ln -s ../isl-$ISLVERSION isl
- mkdir ../avr-gcc-build-$VERSION
- cd ../avr-gcc-build-$VERSION
- export CFLAGS_FOR_TARGET="$SLKCFLAGS"
- export CXXFLAGS_FOR_TARGET="$SLKCFLAGS"
- ../gcc-$VERSION/configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --infodir=/usr/info \
- --mandir=/usr/man \
- --disable-install-libiberty \
- --disable-libssp \
- --disable-libstdcxx-pch \
- --disable-libunwind-exceptions \
- --disable-linker-build-id \
- --disable-nls \
- --disable-werror \
- --disable-__cxa_atexit \
- --enable-checking=release \
- --enable-clocale=gnu \
- --enable-cloog-backend=isl \
- --enable-gnu-unique-object \
- --enable-gnu-indirect-function \
- --enable-gold \
- --enable-languages=c,c++ \
- --enable-ld=default \
- --enable-lto \
- --enable-plugin \
- --enable-shared \
- --target=avr \
- --with-as=/usr/bin/avr-as \
- --with-gnu-as \
- --with-gnu-ld \
- --with-ld=/usr/bin/avr-ld \
- --with-plugin-ld=ld.gold \
- --with-system-zlib \
- --with-dwarf2 \
- --with-isl \
- --program-prefix="avr-" \
- --program-suffix="" \
- --build=$ARCH-slackware-linux
- make || exit 1
- make -j1 install DESTDIR=$PKG || exit 1
- # Remove useless stuff
- rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/libiberty.a
- rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/libcc1.*
- rm -rf $PKG/usr/info
- rm -rf $PKG/usr/include
- rm -rf $PKG/usr/share
- rm -rf $PKG/usr/man/man7
- rm -rf $PKG/usr/libexec/gcc/avr/$VERSION/install-tools
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- for file in COPYING* ChangeLog MAINTAINERS NEWS README*; do
- cp ../gcc-$VERSION/$file $PKG/usr/doc/$PRGNAM-$VERSION
- done
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|