123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125 |
- #!/bin/bash
- # Slackware build script for avr-binutils
- # Written by Marek Buras <cyfr0n (at) go2 !dot pl>
- # Previously maintained by Vliegendehuiskat <vliegendehuiskat [at] gmail [dot] com>
- # Previously maintained by Claudio Henrique Fortes Felix <felix.claudio [at] gmail [dot] com>
- # Now maintained by Heiko Rosemann <heiko [dot] rosemann [at] web [dot] de>
- # This file is placed in the public domain.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=avr-binutils
- VERSION=${VERSION:-2.38}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf binutils-$VERSION
- tar xvf $CWD/binutils-$VERSION.tar.?z*
- cd binutils-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Apply patch for AVR specific output of 'size' (avr-size)
- patch -p1 < $CWD/avr-size.patch
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --infodir=/usr/info \
- --mandir=/usr/man \
- --disable-nls \
- --disable-werror \
- --target=avr \
- --with-gnu-ld \
- --with-gnu-as \
- --with-dwarf2 \
- --enable-install-libbfd \
- --enable-ld=default \
- --enable-gold \
- --enable-plugins \
- --enable-threads \
- --with-pic \
- --enable-shared \
- --disable-multilib \
- --program-prefix="avr-" \
- --program-suffix="" \
- --build=$ARCH-slackware-linux
- make
- make install DESTDIR=$PKG
- # Remove useless stuff
- rm -rf $PKG/usr/lib${LIBDIRSUFFIX}
- rm -rf $PKG/usr/info
- rm -f $PKG/usr/man/man1/avr-dlltool.1
- rm -f $PKG/usr/man/man1/avr-nlmconv.1
- rm -f $PKG/usr/man/man1/avr-windres.1
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a COPYING* ChangeLog MAINTAINERS README* \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|