asem51.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. #!/bin/bash
  2. # Slackware build script for asem51
  3. # Copyright 2014 R. S. Ananda Murthy, Mysore, India
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220408 bkw: Modified by SlackBuilds.org, BUILD=2:
  23. # - don't install redundant upload and upload.new.
  24. # - don't install empty /usr/share dir in package.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=asem51
  27. VERSION=${VERSION:-1.3}
  28. BUILD=${BUILD:-2}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION-ELF.tar.gz
  64. cd $PRGNAM
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  71. mkdir -p $PKG/usr/bin
  72. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  73. mkdir -p $PKG/usr/include/asem51
  74. mkdir -p $PKG/etc/profile.d
  75. cp asem $PKG/usr/bin/asem
  76. cp boot $PKG/usr/bin/boot
  77. cp customiz $PKG/usr/bin/customiz
  78. cp hexbin $PKG/usr/bin/hexbin
  79. cp reset51 $PKG/usr/bin/reset51
  80. # 20220408 bkw: upload and upload.new are almost identical, except
  81. # that upload.new uses "stty -F" instead of redirecting from stdin.
  82. # no reason to install both, and the .new one seems more correct
  83. # to me.
  84. cp upload.new $PKG/usr/bin/upload
  85. mv html $PKG/usr/doc/$PRGNAM-$VERSION/html
  86. mv mcu $PKG/usr/include/asem51
  87. chown -R root:root $PKG/usr/include/asem51
  88. cat <<EOF > $PKG/etc/profile.d/asem51.sh
  89. ASEM51INC=/usr/include/asem51/mcu
  90. export ASEM51INC
  91. EOF
  92. cat <<EOF > $PKG/etc/profile.d/asem51.csh
  93. setenv ASEM51INC /usr/include/asem51/mcu
  94. EOF
  95. chmod +x $PKG/etc/profile.d/asem51.*
  96. cp -a README.1ST $PKG/usr/doc/$PRGNAM-$VERSION
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. mkdir -p $PKG/install
  99. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  100. cat $CWD/slack-desc > $PKG/install/slack-desc
  101. cd $PKG
  102. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE