PhpStorm.SlackBuild 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. #!/bin/bash
  2. # Slackware build script for phpstorm
  3. # Copyright 2023 Joielechong <juansspy@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=PhpStorm
  24. VERSION=${VERSION:-2022.3.3}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. ARCH=${ARCH:-x86_64}
  29. FOLDER=${FOLDER:-PhpStorm-223.8836.42}
  30. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  31. # the name of the created package would be, and then exit. This information
  32. # could be useful to other scripts.
  33. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  34. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  35. exit 0
  36. fi
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. set -e
  41. rm -rf $PKG
  42. mkdir -p $TMP $PKG $OUTPUT
  43. cd $TMP
  44. rm -rf $FOLDER
  45. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  46. cd $FOLDER
  47. chown -R root:root .
  48. find -L . \
  49. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  50. -o -perm 511 \) -exec chmod 755 {} \; -o \
  51. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  52. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  53. mkdir -p $PKG/opt/$PRGNAM
  54. cp -rf * $PKG/opt/$PRGNAM
  55. mkdir -p $PKG/usr/share/applications
  56. cat << EOF > $PKG/usr/share/applications/$PRGNAM.desktop
  57. [Desktop Entry]
  58. Version=1.0
  59. Type=Application
  60. Path=/opt/$PRGNAM
  61. Exec=$PRGNAM %f
  62. Name=PhpStorm
  63. GenericName=Text Editor
  64. Comment=Lightning-smart PHP IDE
  65. Icon=$PRGNAM
  66. StartupNotify=true
  67. Terminal=false
  68. Categories=Development;IDE;
  69. EOF
  70. mkdir -p $PKG/usr/share/pixmaps
  71. install -D -m0644 $PKG/opt/$PRGNAM/bin/phpstorm.png \
  72. $PKG/usr/share/pixmaps/$PRGNAM.png
  73. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  74. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  75. mkdir -p $PKG/usr/bin
  76. ln -sf /opt/$PRGNAM/bin/phpstorm.sh $PKG/usr/bin/$PRGNAM
  77. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  78. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  79. mkdir -p $PKG/install
  80. cat $CWD/slack-desc > $PKG/install/slack-desc
  81. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  82. cd $PKG
  83. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE