paml.SlackBuild 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158
  1. #!/bin/bash
  2. # Slackware build script for paml
  3. # Copyright 2013-2022 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=paml
  24. VERSION=${VERSION:-4.10.5}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686 -fcommon"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686 -fcommon"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC -fcommon"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2 -fcommon"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf ${PRGNAM}-${VERSION}
  63. tar xvf $CWD/${PRGNAM}-${VERSION}.tar.gz
  64. cd ${PRGNAM}-${VERSION}
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. # Use our CFLAGS
  72. sed -i "/^C.*.*FLAGS/s/=/+=/" src/Makefile
  73. # These are the main components, and most likely this will be all you
  74. # need. Check the next sections if you need some optional components.
  75. # They will be installed to /usr/libexec/paml in case you want them.
  76. cd src
  77. CFLAGS="$SLKCFLAGS" \
  78. make -f Makefile
  79. install -D -m755 baseml $PKG/usr/bin/baseml
  80. install -D -m755 basemlg $PKG/usr/bin/basemlg
  81. install -D -m755 chi2 $PKG/usr/bin/chi2
  82. install -D -m755 codeml $PKG/usr/bin/codeml
  83. install -D -m755 evolver $PKG/usr/bin/evolver
  84. install -D -m755 mcmctree $PKG/usr/bin/mcmctree
  85. install -D -m755 pamp $PKG/usr/bin/pamp
  86. install -D -m755 yn00 $PKG/usr/bin/yn00
  87. # Compile and install Evolver variations
  88. cc $SLKCFLAGS -DCodonNSbranches -o evolverNSbranches evolver.c tools.c -lm
  89. cc $SLKCFLAGS -DCodonNSsites -o evolverNSsites evolver.c tools.c -lm
  90. cc $SLKCFLAGS -DCodonNSbranchsites -o evolverNSbranchsites evolver.c tools.c -lm
  91. install -D -m755 evolverNSbranches $PKG/usr/libexec/$PRGNAM/evolverNSbranches
  92. install -D -m755 evolverNSbranchsites $PKG/usr/libexec/$PRGNAM/evolverNSbranchsites
  93. install -D -m755 evolverNSsites $PKG/usr/libexec/$PRGNAM/evolverNSsites
  94. # This does not build at the moment, so let's disable it for now
  95. # # Compile and install TreeTime
  96. # cc $SLKCFLAGS -o TreeTimeJeff TreeTimeJeff.c tools.c -lm
  97. # install -D -m755 TreeTimeJeff $PKG/usr/libexec/$PRGNAM/TreeTimeJeff
  98. # Compile and install NEB, BEB and BranchSite
  99. cd ../Technical/Simulation/Codon
  100. cc $SLKCFLAGS -DNEB -o PositiveSitesNEB PositiveSites.c -lm
  101. cc $SLKCFLAGS -DBEB -o PositiveSitesBEB PositiveSites.c -lm
  102. cc $SLKCFLAGS -DBranchSite -o PositiveSitesBS PositiveSites.c -lm
  103. install -D -m755 PositiveSitesBEB $PKG/usr/libexec/$PRGNAM/PositiveSitesBEB
  104. install -D -m755 PositiveSitesBS $PKG/usr/libexec/$PRGNAM/PositiveSitesBS
  105. install -D -m755 PositiveSitesNEB $PKG/usr/libexec/$PRGNAM/PositiveSitesNEB
  106. # Compile and install Multiruns
  107. cd ..
  108. cc -o multiruns $SLKCFLAGS multiruns.c -lm
  109. install -D -m755 multiruns $PKG/usr/libexec/$PRGNAM/multiruns
  110. cd $TMP/${PRGNAM}-${VERSION}
  111. # Include sample system files and example experimental data.
  112. mkdir -p $PKG/usr/share/$PRGNAM/Simulation/Codon
  113. cp -a src/*.ctl dat $PKG/usr/share/$PRGNAM
  114. cp -a Technical/Simulation/Codon/{codeml.ctl,*.dat,README.txt} \
  115. $PKG/usr/share/$PRGNAM/Simulation/Codon
  116. cp -a examples $PKG/usr/share/$PRGNAM
  117. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  118. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  119. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  120. cp -a README.md LICENSE doc/* \
  121. $PKG/usr/doc/$PRGNAM-$VERSION
  122. cp Technical/Pt/eigenQREV.pdf $PKG/usr/doc/$PRGNAM-$VERSION
  123. cp $CWD/MCMCtreeDOC.pdf $PKG/usr/doc/$PRGNAM-$VERSION
  124. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  125. # Fix permissions.
  126. find $PKG/usr/{doc,share} -type d -exec chmod 755 {} \; -o \
  127. -type f -exec chmod 644 {} \;
  128. mkdir -p $PKG/install
  129. cat $CWD/slack-desc > $PKG/install/slack-desc
  130. cd $PKG
  131. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE