aline.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100
  1. #!/bin/bash
  2. # Slackware build script for aline
  3. # Copyright 2013-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=aline
  24. VERSION=${VERSION:-1.0.025}
  25. BUILD=${BUILD:-2}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCVER=011208
  29. ARCH=noarch
  30. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  31. # the name of the created package would be, and then exit. This information
  32. # could be useful to other scripts.
  33. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  34. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  35. exit 0
  36. fi
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. # Maximum row length. The default is 100 and will not be changed,
  41. # unless you pass some other value to the script.
  42. ROW=${ROW:-100}
  43. set -e
  44. rm -rf $PKG
  45. mkdir -p $TMP $PKG $OUTPUT
  46. cd $TMP
  47. rm -rf ${PRGNAM}_${SRCVER}
  48. tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.gz
  49. cd ${PRGNAM}_${SRCVER}
  50. chown -R root:root .
  51. find -L . \
  52. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  53. -o -perm 511 \) -exec chmod 755 {} \; -o \
  54. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  55. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  56. # Point aline to the correct paths of its colour schemes, examples,
  57. # plugins and scripts.
  58. sed -i "s:%%SELFcolourschemes:/usr/share/$PRGNAM/colourschemes:g" bin/aline
  59. sed -i "s:%%SELFexample:/usr/share/$PRGNAM/example:g" bin/aline
  60. sed -i "s:%%SELFplugins:/usr/share/$PRGNAM/plugins:g" bin/aline
  61. sed -i "s:%%SELFscripts:/usr/share/$PRGNAM/scripts:g" bin/aline
  62. # Change the maximum row length to a value you specify.
  63. [ ! "$ROW" = "100" ] && sed -i "s:10,100,40:10,$ROW,40:g" bin/aline
  64. install -D -m755 bin/$PRGNAM $PKG/usr/bin/$PRGNAM
  65. install -D -m755 bin/convertdump $PKG/usr/bin/convertdump
  66. mkdir -p $PKG/usr/share/$PRGNAM/
  67. cp -a \
  68. colourschemes example plugins \
  69. $PKG/usr/share/$PRGNAM/
  70. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  71. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  72. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  73. # Couldn't find an icon, so I assembled this thing from the program's logo...
  74. mkdir -p $PKG/usr/share/{applications,pixmaps}
  75. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  76. cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps
  77. mkdir -p $PKG/install
  78. cat $CWD/slack-desc > $PKG/install/slack-desc
  79. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  80. cd $PKG
  81. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE