OpenMM.SlackBuild 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. #!/bin/bash
  2. # Slackware build script for OpenMM
  3. # Copyright 2022 William PC - Seattle, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=OpenMM
  24. VERSION=${VERSION:-7.7.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCNAM=${PRGNAM,,}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $SRCNAM-$VERSION
  64. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  65. cd $SRCNAM-$VERSION
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. # fix library installation path
  73. # note: the other solution requires less lines,
  74. # but it was after cmake
  75. sed -i \
  76. -e 's#/lib RUNTIME_DIRECTORY /lib#/lib'${LIBDIRSUFFIX}' RUNTIME_DIRECTORY /lib'${LIBDIRSUFFIX}'#' \
  77. -e 's#/lib/plugins RUNTIME_DIRECTORY /lib/plugins#/lib'${LIBDIRSUFFIX}'/plugins RUNTIME_DIRECTORY /lib'${LIBDIRSUFFIX}'/plugins#' \
  78. platforms/*/*/CMakeLists.txt \
  79. plugins/*/CMakeLists.txt \
  80. plugins/*/platforms/*/CMakeLists.txt
  81. sed -i 's#${CMAKE_INSTALL_PREFIX}/lib#&'${LIBDIRSUFFIX}'#' \
  82. plugins/*/CMakeLists.txt \
  83. plugins/*/platforms/*/CMakeLists.txt \
  84. platforms/*/CMakeLists.txt \
  85. platforms/*/*/CMakeLists.txt
  86. # fix installation path for examples and licenses
  87. sed -i 's#\(DESTINATION\) \(examples\)#\1 share/'$PRGNAM'/\2#' \
  88. examples/CMakeLists.txt
  89. sed -i 's#\(DESTINATION\) \(licenses\)#\1 doc/'$PRGNAM-$VERSION'/\2#' \
  90. docs-source/CMakeLists.txt
  91. mkdir -p build
  92. cd build
  93. cmake \
  94. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  95. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  96. -DCMAKE_INSTALL_PREFIX=/usr \
  97. -DBUILD_SHARED_LIBS=ON \
  98. -DPYTHON_EXECUTABLE=/usr/bin/python3 \
  99. $OPT_BUILD \
  100. -DCMAKE_BUILD_TYPE=Release ..
  101. # fix installation path of library "libOpenMM.so"
  102. sed -i 's#${CMAKE_INSTALL_PREFIX}/lib#&'${LIBDIRSUFFIX}'#' \
  103. cmake_install.cmake
  104. make
  105. make install/strip DESTDIR=$PKG
  106. if [ ${PYTHON:-no} == yes ]; then
  107. cd python
  108. # require the CFLAGS for linking with the OpenMM libraries
  109. CFLAGS="-L$PKG/usr/lib${LIBDIRSUFFIX}" \
  110. OPENMM_INCLUDE_PATH="/usr/include;$PKG/usr/include" \
  111. OPENMM_LIB_PATH="/usr/lib${LIBDIRSUFFIX};$PKG/usr/lib${LIBDIRSUFFIX}" \
  112. python3 setup.py install --root=$PKG
  113. # remove temporary folder from python module library path
  114. PYVER=$( python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])' )
  115. sed -i 's#;'$PKG'/usr/lib'${LIBDIRSUFFIX}'##' $PKG/usr/lib${LIBDIRSUFFIX}/python$PYVER/site-packages/openmm/version.py
  116. cd ..
  117. fi
  118. cd ..
  119. # update example's makefile
  120. sed -i \
  121. -e '21s#/usr/local/openmm#/usr#' \
  122. -e '31s#/lib#&'${LIBDIRSUFFIX}'#' \
  123. $PKG/usr/share/$PRGNAM/examples/Makefile
  124. # prune empty dirc "usr/docs"
  125. rm -fr $PKG/usr/docs
  126. # Don't ship .la files:
  127. rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
  128. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  129. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  130. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  131. cp -a \
  132. {CODE_OF_CONDUCT,CONTRIBUTING,SUPPORT}.md \
  133. $PKG/usr/doc/$PRGNAM-$VERSION
  134. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  135. mkdir -p $PKG/install
  136. cat $CWD/slack-desc > $PKG/install/slack-desc
  137. cd $PKG
  138. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE