123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166 |
- #!/bin/bash
- # Slackware build script for RAxML
- # Copyright 2019-2021 Petar Petrov slackalaxy@gmail.com
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=RAxML
- VERSION=${VERSION:-8.2.12}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf standard-$PRGNAM-$VERSION
- tar xvf $CWD/standard-$PRGNAM-$VERSION.tar.gz
- cd standard-$PRGNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Build executables with the default Slackware compiler flags.
- # Sequential version
- cp Makefile.gcc Makefile
- sed -i "/^CFLAGS/s/=/+=/" Makefile
- sed -i "s|raxmlHPC|raxml|g" Makefile
- CFLAGS="$SLKCFLAGS" \
- make -f Makefile -j1
- install -D -m755 raxml $PKG/usr/bin/raxml
- # Openmpi version
- cp Makefile.MPI.gcc Makefile.MPI
- sed -i "/^CFLAGS/s/=/+=/" Makefile.MPI
- sed -i "s|raxmlHPC-MPI|raxml-MPI|g" Makefile.MPI
- CFLAGS="$SLKCFLAGS" \
- make -f Makefile.MPI -j1
- install -D -m755 raxml-MPI $PKG/usr/bin/raxml-MPI
- ##########################################################################
- ### You are highly encouraged to try the other optimisations below for ###
- ### performance enhancements. Just uncomment the corresponding lines. ###
- ##########################################################################
- ## Default sequential version
- #make -f Makefile.gcc
- #install -D -m755 raxmlHPC $PKG/usr/bin/raxmlHPC
- #make -f Makefile.SSE3.gcc
- #install -D -m755 raxmlHPC-SSE3 $PKG/usr/bin/raxmlHPC-SSE3
- #make -f Makefile.AVX.gcc
- #install -D -m755 raxmlHPC-AVX $PKG/usr/bin/raxmlHPC-AVX
- ## Pthreads version
- #make -f Makefile.PTHREADS.gcc
- #install -D -m755 raxmlHPC-PTHREADS $PKG/usr/bin/raxmlHPC-PTHREADS
- #make -f Makefile.SSE3.PTHREADS.gcc
- #install -D -m755 raxmlHPC-PTHREADS-SSE3 $PKG/usr/bin/raxmlHPC-PTHREADS-SSE3
- #make -f Makefile.AVX.PTHREADS.gcc
- #install -D -m755 raxmlHPC-PTHREADS-AVX $PKG/usr/bin/raxmlHPC-PTHREADS-AVX
- ## Default coarse-grain MPI version
- #make -f Makefile.MPI.gcc
- #install -D -m755 raxmlHPC-MPI $PKG/usr/bin/raxmlHPC-MPI
- #make -f Makefile.SSE3.MPI.gcc
- #install -D -m755 raxmlHPC-MPI-SSE3 $PKG/usr/bin/raxmlHPC-MPI-SSE3
- #make -f Makefile.AVX.MPI.gcc
- #install -D -m755 raxmlHPC-MPI-AVX $PKG/usr/bin/raxmlHPC-MPI-AVX
- ## Hybrid MPI/Pthreads version
- # Before using this version, please read this paper here:
- # http://sco.h-its.org/exelixis/pubs/Exelixis-RRDR-2010-3.pdf
- # and look at these slides:
- # http://sco.h-its.org/exelixis/resource/doc/Phylo100225.pdf
- #make -f Makefile.HYBRID.gcc
- #install -D -m755 raxmlHPC-HYBRID $PKG/usr/bin/raxmlHPC-HYBRID
- #make -f Makefile.SSE3.HYBRID.gcc
- #install -D -m755 raxmlHPC-HYBRID-SSE3 $PKG/usr/bin/raxmlHPC-HYBRID-SSE3
- #make -f Makefile.AVX.HYBRID.gcc
- #install -D -m755 raxmlHPC-HYBRID-AVX $PKG/usr/bin/raxmlHPC-HYBRID-AVX
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- # Copy the useful scripts
- mkdir -p $PKG/usr/share/$PRGNAM
- cp -a usefulScripts $PKG/usr/share/$PRGNAM
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a README manual $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|