eyeD3.SlackBuild 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. #!/bin/sh
  2. # Slackware build script for abiword
  3. # Copyright 2007 Andrew Lindberg <alindberg@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Modified by the SlackBuilds.org project
  23. # No additional license terms added
  24. PRGNAM=eyeD3
  25. VERSION=0.6.14
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. # Automatically determine the architecture we're building on:
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i486 ;;
  32. arm*) ARCH=arm ;;
  33. # Unless $ARCH is already set, use uname -m for all other archs:
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. CWD=$(pwd)
  38. TMP=${TMP:-/tmp/SBo}
  39. PKG=$TMP/package-$PRGNAM
  40. OUTPUT=${OUTPUT:-/tmp}
  41. set -e
  42. rm -rf $PKG
  43. mkdir -p $TMP $PKG $OUTPUT
  44. cd $TMP
  45. rm -rf $PRGNAM-$VERSION
  46. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  47. cd $PRGNAM-$VERSION
  48. chown -R root:root .
  49. chmod -R u+w,go+r-w,a-s .
  50. # eyeD3 neatly wraps the setup.py script in an automake system
  51. # --docdir is ignored by the build process, but we'll leave it here anyway
  52. ./configure \
  53. --prefix=/usr \
  54. --libdir=/usr/lib${LIBDIRSUFFIX} \
  55. --sysconfdir=/etc \
  56. --localstatedir=/var \
  57. --mandir=/usr/man \
  58. --docdir=/usr/doc/$PRGNAM-$VERSION
  59. make
  60. make DESTDIR=$PKG install
  61. # and the automake does everything neatly for docs and man pages, et al
  62. # just need the slack-specific files
  63. mv $PKG/usr/share/doc $PKG/usr
  64. rmdir $PKG/usr/share
  65. ( cd $PKG/usr/doc/$PRGNAM-$VERSION
  66. cat $CWD/$PRGNAM.SlackBuild > $PRGNAM.SlackBuild
  67. gzip -d {COPYING.gz,ChangeLog.gz}
  68. )
  69. mkdir -p $PKG/install
  70. cat $CWD/slack-desc > $PKG/install/slack-desc
  71. cd $PKG
  72. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}