1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495 |
- #!/bin/bash
- # Slackware build script for cd-discid
- # Copyright 2007 Jim Capozzoli <saltmiser@gmail.com>
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Modified by the SlackBuilds.org project
- PRGNAM=cd-discid
- VERSION=0.9
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- # Automatically determine the architecture we're building on:
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- mkdir -p $TMP $PKG $OUTPUT
- rm -rf $PKG $TMP/$PRGNAM-$VERSION
- cd $TMP
- tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- chmod -R u+w,go+r-w,a-s .
- # Apply a patch to Makefile to fix mandir and prevent setting ownership during
- # the install. The mandir could easily be done by passing the 'mandir'
- # variable to 'make install' but the ownership setting can't be omitted any
- # other way. This isn't a huge issue, but I'm probably not the only one who
- # likes to test scripts as a normal user before running them as root, and the
- # ownership setting has to be removed for that to work. --rworkman
- patch -p1 < $CWD/Makefile.diff
- make CFLAGS+="$SLKCFLAGS"
- make install DESTDIR=$PKG
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a COPYING README changelog $PKG/usr/doc/$PRGNAM-$VERSION
- find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- strip --strip-unneeded $PKG/usr/bin/cd-discid
- gzip -9 $PKG/usr/man/man1/*.?
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|