jpicedt.SlackBuild 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. #!/bin/sh
  2. # Copyright 2008 Robert Allen - slacker@slaphappygeeks.com
  3. # All rights reserved including Creator Endowed Unalienable Rights.
  4. #
  5. # Redistribution and use of this script, with or without modification, is
  6. # permitted provided that the following conditions are met:
  7. #
  8. # 1. Redistributions of this script must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. #
  11. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  12. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  13. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  14. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  15. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  16. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  17. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  18. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  19. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  20. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  21. PRGNAM=jpicedt
  22. VERSION=${VERSION:-1.4.1_03}
  23. BUILD=${BUILD:-1}
  24. TAG=${TAG:-_SBo}
  25. # Automatically determine the architecture we're building on:
  26. if [ -z "$ARCH" ]; then
  27. case "$( uname -m )" in
  28. i?86) ARCH=i486 ;;
  29. arm*) ARCH=arm ;;
  30. # Unless $ARCH is already set, use uname -m for all other archs:
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. CWD=$(pwd)
  35. TMP=${TMP:-/tmp/SBo}
  36. PKG=$TMP/package-$PRGNAM
  37. OUTPUT=${OUTPUT:-/tmp}
  38. if [ "$ARCH" = "i486" ]; then
  39. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  40. LIBDIRSUFFIX=""
  41. elif [ "$ARCH" = "i686" ]; then
  42. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  43. LIBDIRSUFFIX=""
  44. elif [ "$ARCH" = "x86_64" ]; then
  45. SLKCFLAGS="-O2 -fPIC"
  46. LIBDIRSUFFIX="64"
  47. else
  48. SLKCFLAGS="-O2"
  49. LIBDIRSUFFIX=""
  50. fi
  51. set -e
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. mkdir -p $PKG/opt/$PRGNAM-$VERSION
  55. unzip $CWD/jpicedt-install_1_4_1_03_20071021.jar -d $PKG/opt/$PRGNAM-$VERSION
  56. # Add a convenience symlink to keep path simple
  57. ( cd $PKG/opt ; ln -s $PRGNAM-$VERSION $PRGNAM )
  58. # Install a wrapper script to start jpicedit
  59. mkdir -p $PKG/usr/bin
  60. sed -e "s|/usr/lib/java|/usr/lib$LIBDIRSUFFIX/java|" \
  61. $CWD/jpicedt.sh > $PKG/usr/bin/jpicedt
  62. chmod 755 $PKG/usr/bin/jpicedt
  63. # Remove META-INF/, installer/, windows addons from the package
  64. rm -rf $PKG/opt/$PRGNAM-$VERSION/{META-INF,installer,add-ons/windows}
  65. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  66. ( cd $PKG/usr/doc/$PRGNAM-$VERSION
  67. for doc in \
  68. COPYING.txt quickstart.html readme.html api-doc help-files add-ons ;
  69. do ln -s $PKG/opt/$PRGNAM-$VERSION/$doc . ;
  70. done
  71. )
  72. mkdir -p $PKG/install
  73. cat $CWD/slack-desc > $PKG/install/slack-desc
  74. cd $PKG
  75. chown -R root:root .
  76. /sbin/makepkg -c n -l y $OUTPUT/${PRGNAM}-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}