icc_profiles.SlackBuild 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. #!/bin/bash
  2. # Slackware build script for Rec709 and related ITU color profiles
  3. # Copyright 2019 Klaatu | Lawrence, NZ | klaatu@member.fsf.org
  4. # GNU All-Permissive License
  5. # Copying and distribution of this file, with or without modification,
  6. # are permitted in any medium without royalty provided the copyright
  7. # notice and this notice are preserved. This file is offered as-is,
  8. # without any warranty.
  9. # 20220222 bkw: Modified by SlackBuilds.org: don't try to install the
  10. # nonexisent lecalcode.txt. How did this script ever get past QA?
  11. cd $(dirname $0) ; CWD=$(pwd)
  12. PRGNAM=icc_profiles
  13. SRCNAM="ICC Profiles - hbrendel.com"
  14. UNION=ITU
  15. VERSION=${VERSION:-2019}
  16. BUILD=${BUILD:-1}
  17. TAG=${TAG:-_SBo}
  18. PKGTYPE=${PKGTYPE:-tgz}
  19. ARCH=noarch
  20. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  21. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  22. exit 0
  23. fi
  24. TMP=${TMP:-/tmp/SBo}
  25. PKG=$TMP/package-$PRGNAM
  26. OUTPUT=${OUTPUT:-/tmp}
  27. set -e
  28. rm -rf $PKG
  29. mkdir -p $TMP $PKG $OUTPUT
  30. cd $TMP
  31. rm -rf $PRGNAM-$VERSION
  32. mkdir -p $PRGNAM-$VERSION
  33. cd $PRGNAM-$VERSION
  34. unzip $CWD/$PRGNAM.zip
  35. install -d $PKG/usr/share/color/icc/$UNION
  36. install -o root -g root -m644 "${SRCNAM}"/*.icc \
  37. $PKG/usr/share/color/icc/$UNION
  38. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  39. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  40. mkdir -p $PKG/install
  41. cat $CWD/slack-desc > $PKG/install/slack-desc
  42. cd $PKG
  43. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE