123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105 |
- #!/bin/sh
- # Slackware build script for moodbar
- # Copyright 2008 Andrew Psaltis <ampsaltis@gmail.com>
- # All rights reserved.
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Modified by SlackBuilds.org
- set -e
- DOCS="AUTHORS COPYING INSTALL NEWS README TODO"
- PRGNAM=moodbar
- VERSION=0.1.2
- ARCH=${ARCH:-i486}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- CWD=$(pwd)
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- case $ARCH in
- i[456]86)
- SLKCFLAGS="-O2 -march=$ARCH -mtune=i686"
- SLKLDFLAGS="" ; LIBDIRSUFFIX=""
- ;;
- s390) # Maybe you want to cross-compile
- SLKCFLAGS="-O2"
- SLKLDFLAGS="" ; LIBDIRSUFFIX=""
- ;;
- powerpc)
- SLKCFLAGS="-O2"
- SLKLDFLAGS=""; LIBDIRSUFFIX=""
- ;;
- x86_64)
- SLKCFLAGS="-O2 -fPIC"
- SLKLDFLAGS="-L/usr/lib64" ; LIBDIRSUFFIX="64"
- ;;
- athlon-xp)
- SLKCFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer"
- SLKLDFLAGS=""; LIBDIRSUFFIX=""
- ;;
- esac
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xfvz $CWD/$PRGNAM-$VERSION.tar.gz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- chmod -R u+w,go+r-w,a-s .
- # Apply patch to fix currently unfixed bug
- # This has been fixed in SVN, but has not been applied to a release.
- # And no releases have been made for quite some time. So...
- patch -p1 < $CWD/$PRGNAM-$VERSION-glib.patch
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-gnu-ld \
- --disable-static \
- --build=$ARCH-slackware-linux
- make
- make install DESTDIR=$PKG
- # Strip binaries and libraries
- ( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- )
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|