amrwb.SlackBuild 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889
  1. #!/bin/sh
  2. # Slackware build script for amrwb
  3. # Copyright 2007-2008 Heinz Wiesinger <hmwiesinger@gmx.at>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. PRGNAM=amrwb
  23. VERSION=7.0.0.3
  24. ARCH=${ARCH:-i486}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. CWD=$(pwd)
  28. TMP=${TMP:-/tmp/SBo}
  29. PKG=$TMP/package-$PRGNAM
  30. OUTPUT=${OUTPUT:-/tmp}
  31. if [ "$ARCH" = "i486" ]; then
  32. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  33. elif [ "$ARCH" = "i686" ]; then
  34. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  35. elif [ "$ARCH" = "x86_64" ]; then
  36. SLKCFLAGS="-O2 -fPIC"
  37. fi
  38. set -e
  39. rm -rf $PKG
  40. mkdir -p $TMP $PKG $OUTPUT
  41. cd $TMP
  42. rm -rf $PRGNAM-$VERSION
  43. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  44. cd $PRGNAM-$VERSION
  45. chown -R root:root .
  46. chmod -R u+w,go+r-w,a-s .
  47. CFLAGS="$SLKCFLAGS" \
  48. CXXFLAGS="$SLKCFLAGS" \
  49. ./configure \
  50. --prefix=/usr \
  51. --sysconfdir=/etc \
  52. --enable-shared \
  53. --disable-static \
  54. --localstatedir=/var \
  55. --build=$ARCH-slackware-linux \
  56. --host=$ARCH-slackware-linux
  57. if [ -e $CWD/26204-700.zip ]; then
  58. cp $CWD/26204-700.zip .
  59. else
  60. echo
  61. echo "$CWD/26204-700.zip was not found."
  62. echo "Go back and read $CWD/README again."
  63. echo
  64. exit 1
  65. fi
  66. make
  67. make install-strip DESTDIR=$PKG
  68. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  69. cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO \
  70. $PKG/usr/doc/$PRGNAM-$VERSION
  71. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  72. mkdir -p $PKG/install
  73. cat $CWD/slack-desc > $PKG/install/slack-desc
  74. cd $PKG
  75. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz